1. Vërum

    Vërum Naked Wanderer

    I have tried both with Rusty and rcon.io, can't seem to connect. I've tried to add +1 on rconport yet no success. I read somewhere that it might be the Rusty Client that isn't updated. I've tried to redownload it just to make sure to get the latest version.

    btw, in /ruste/config, all I have there is config.vdf

    Image 1
    Image 2
     
  2. Wombat

    Wombat Shack Builder

    make sure you change the rcon info in your server command line and then boot your server up and should be good
     
  3. Resistance

    Resistance Grenade Master

    image 2 wrong file go to server folder
     
  4. Vërum

    Vërum Naked Wanderer

    I can get access to rcon.io with my inlog information. But, I can not seem to get access to the Rusty client.

    It looks like this after connecting: Image

    I have tried different passwords, it doesn't change. So I am not connected, although I use the same info on Rusty as on rcon.io
    --- Double Post Merged, Jun 25, 2017 ---
    I think I found out why I couldn't use Rusty when I could use rcon.io

    I had to add +rcon.web 0 +rcon.ip "xxx.xxx.xx.xx." to the command line.

    I guess you can't use web rcon and offline-based rcon together, guess you have to choose from one of them
    --- Double Post Merged, Jun 25, 2017 ---
    Yup, that was it (click me)
     
  5. Wombat

    Wombat Shack Builder

    Rusty Rcon no longer works even with the Rcon.Web 0 you need to go into you server command line and change this options to 1
    Rcon.Web 1 then when you try and connect with rustadmin you need to select configuration and WebRcon default ports are server port 28015 and Rcon port is 28016

    Rcon.Web (web(1)/hl2(0))
     
  6. Vërum

    Vërum Naked Wanderer

    Works for me now though
     
  7. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The old protocol still works fine. Oxide also provides the protocol that rcon.web 0 uses, which also works with Rusty and RustAdmin.
     
  8. Wombat

    Wombat Shack Builder

    i cannot get this to work on both of my servers since 2 updates ago same with other people i know who run servers it dosent work for them either
     
  9. Zooke

    Zooke Naked Wanderer

    Hey, ive been using the command ownerid <steam id> "Name" in rusty and when i used it for my friends they became the admin (green name in chat) but when i use it for my own username i dont have a green username and i cannot use admin commands. Is there any way to stop this? by the way the config file is showing my name in the list and i have restarted the server several times to see if it would update.
     
  10. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Make sure you used server.writecfg after using the ownerid command and that you've disconnected and reconnected to the server after. Also make sure you are using the main Steam ID, not any family sharing ID.
     
  11. Zooke

    Zooke Naked Wanderer

    I have been, everytime i used server.writecfg i even edited the config file manually, ive restarted server, disconnected, reconnected, i copied the steamID directly from rusty that shows all the usernames, i know how to add people to admin as ive added every single other user, but when i try my own yet to no avail
     
  12. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Make sure the Steam ID you are using matches what you see in your server logs/console when you connect.
     
  13. Zooke

    Zooke Naked Wanderer

    it does, ive checked through multiple sources, from rusty (it clearly is the right steamID as it allows me to give items, grant myself permissions, and if i check on a steamid checker it all shows the same, i checked the logs and it shows the same id i addedd to the list, its 100% the correct id, like i said it works for every user except for me
     
  14. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    So the only issue is your name color?
     
  15. Zooke

    Zooke Naked Wanderer

    No, not just the color, i dont even have access to the admin commands like noclip.
     
  16. Zooke

    Zooke Naked Wanderer

    Fixed it myself, i looked into a config file that held all the users and their permissions etc, i noticed i had every permission including all the oxide ones as i ran the command grant user <my id> * and the wildcard caused me not to show as admin. now i removed all my perms i am now showing as admin :)
     
  17. Jackstallion

    Jackstallion Naked Wanderer

    Hey guys, big noob here, i just started to put together a server hosted off gameservers, and i am using the RUSTADMIN tool, my real question is how do i set up admin IN GAME so that i can use ingame console commands and such, if this isnt the place for this on the forums let me know.
     
  18. Jackstallion

    Jackstallion Naked Wanderer

    thanks for sending me here, now when using rusty, it says not connected but the box is green, but i know i input the rcon port, etc in properly because its the same as what i was using for rustadmin tool, but then it disconnects me after a few. is it because im running the rustadmin tool at the same time?
     
  19. Resistance

    Resistance Grenade Master

    Read the first post also dont go with gameservers they are crap
     
  20. Rust Basics

    Rust Basics Naked Wanderer

    Hello i would love to be able to use my admin powers again. I have recently followed the rustified guide to running a rust server and everything went great! i had admin powers and everything. The next day i ran the server and my admin powers are gone i have tried removing and adding myself as ownerid and modid. i reinstalled the SteamCMD and rustserver updated it and did everything. The only thing i didn't do last time that i did this time was write "server.writecfg" after writing ownerid,once I did that launched rust and still nothing i have restarted everything. if a video is needed to provide anything i am willing to do that. Please get back to me asap kind regards, me :p