We've moved! Join us as we continue development on our new site at umod.org!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Wulf

    Wulf Community Admin

    Check your RustDedicated_Data/output_log.txt for errors.
     
  2. I do not see an output_log.txt
     
  3. Wulf

    Wulf Community Admin

    Check the location you have set with -logfile then.
     
  4. I think I got it to work thanks!
    [DOUBLEPOST=1486766682][/DOUBLEPOST]ok all looks good in the console but when I go to join the server this happens
     

    Attached Files:

  5. which of there ports are the UDP or the TCP 28015 and 28016

    I'm new on hosting an rust server so I need to find out which one is
     
    Last edited by a moderator: Feb 18, 2017
  6. Wulf

    Wulf Community Admin

    28015 (game port) would be UDP, 28016 (RCON) would be TCP.
     
  7. Wulf, since there is no way to contact you, is it possible, somehow, to look in to this 2fps issue a bunch of us seem to be having?
     
  8. Wulf

    Wulf Community Admin

    I'd recommend discussing it in your other threads. It's not an issue with Oxide, it'd be with plugins, Rust, or your setup.
     
  9. Ok, can you comment in there? It's only been the last two patches this has happened, and happens without any plugins loaded.
     
  10. Wulf

    Wulf Community Admin

    Oxide itself does essentially nothing other than provide a custom console and core commands when no plugins are loaded, which none of that has changed.
     
  11. [Stacktrace] at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
    at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] param
    22:30 [Error] Failed to call hook 'OnPlayerTick' on plugin 'RustCore v2.0.3097' (FieldAccessException: Field `BasePlayer:serverInput' is ina
    ccessible from method `Oxide.Game.Rust.RustCore:OnPlayerTick (BasePlayer)')
    Hi. Give me pls fix.
     
  12. Wulf

    Wulf Community Admin

    That isn't an issue from our builds, sounds like you are using an old patched Assembly-CSharp.dll for Rust.
     
  13. So after a restart, I updated my plugins and now all plugins will not load. The server starts up, no errors are in the log but no oxide plugins load. Also, Rusty shows no players in the players list but the rest of rusty works fine...
     
  14. Wulf

    Wulf Community Admin

    Check your oxide/logs for errors.
     
  15. I did, no errors.. It loads Oxide but seems to skip the plugin loading..
    [DOUBLEPOST=1488068544][/DOUBLEPOST]All I have in log error is from LustyMaps

    [02/25/2017 17:12:50] [LustyMap] You must supply a valid API key to utilize the auto-download feature!
    Visit 'beancan.io' and register your server to retrieve your API key!
    [02/25/2017 17:21:15] [LustyMap] The plugin has timed out trying to find the map image to split! Complex map has been disabled
    [02/25/2017 17:24:36] [LustyMap] The plugin has timed out trying to find the map image to split! Complex map has been disabled

    These are from back when the rest of the plugins worked.. None of the new startup attempts have any errors at all.
     
  16. Wulf

    Wulf Community Admin

    If LustyMap is loading, it isn't skipping them. Could you upload the full log file please? Also test the "oxide.version" command in your console or RCON.
     
  17. I edited my previous response...
    [DOUBLEPOST=1488068691][/DOUBLEPOST]oxide.version returns nothing
     
  18. Wulf

    Wulf Community Admin

    Sounds like Oxide isn't setup or not install then. Could you upload your RustDedicated_Data/output_log.txt here please?
     
  19. I use..


    Rustide v1.42 by Jarsky
    This script auto updates Rust + Oxide Mod
    Updated 21 October 2016

    For starting and ir updates and or verifies Oxide and the Rust Server
     
  20. Wulf

    Wulf Community Admin

    That doesn't guarantee it is installed. ;)