We've moved! Join us as we continue development on our new site at umod.org!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rust-Kits

Moved

Total Downloads: 69,999 - First Release: Oct 21, 2014 - Last Update: Jun 7, 2018

4.96216/5, 185 likes
  1. Follow the below please in rcon
    1. unload plugin
    2. delete the kits_data.json file from the data folder
    3. upload the files I posted
    4. reload the plugin
    5. login to game and type /kit and make sure its all ok
    Please test if any errors report

    And make sure you upload the files I give you not the ones you had before as they are messed up as the two you just posted above are not done right
     

    Attached Files:

  2. dont working...i can send to u my teamwiever pass
    I edited but not working
     

    Attached Files:

  3. need error if any and I only use skype
     
  4. thx but my english not good dude
     
  5. I made a few small changes

    Follow the below please in rcon
    1. unload plugin
    2. delete the kits_data.json file from the data folder
    3. upload the files I posted
    4. reload the plugin
    5. login to game and type /kit and make sure its all ok
    Please test if any errors report
     

    Attached Files:

    Last edited by a moderator: Aug 3, 2018
  6. there is no image connect to the kits and when i do /kit it just comes up with a blank screen
     
  7. Updated my server and found a new issue with the kits plugin. I'm using the latest one to download.
    When you open the /kit UI and select the kit... the close button vanishes so you cannot exit the UI screen.
    This causes me to remove the KIT plugin and put it back into the plugin folder to help players get out of the glitch without leaving the server.

    Failed to call hook 'cmdChatKit' on plugin 'Kits v3.2.92' (NullReferenceException: Object reference not set to an instance of an object)
    at Oxide.Plugins.Kits+UI.LoadImage (Oxide.Game.Rust.Cui.CuiElementContainer& container, System.String panel, System.String img, System.String aMin, System.String aMax) [0x00000] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.Kits.CreateKitEntry (BasePlayer player, Oxide.Game.Rust.Cui.CuiElementContainer& element, System.String panel, System.Single[] pos, System.String entry) [0x0011b] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.Kits.RefreshKitPanel (BasePlayer player, System.UInt64 guiId, System.Int32 page) [0x001de] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.Kits.NewKitPanel (BasePlayer player, System.UInt64 guiId) [0x00022] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.Kits.cmdChatKit (BasePlayer player, System.String command, System.String[] args) [0x0001a] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.Kits.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x0102a] in <1788989f294b4f22b5953a9161998de6>:0
    at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <e5ac390771dc411395a594de571775c7>:0
    at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <fc2b4388d9974d719a0972b08cea0f17>:0
    at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <fc2b4388d9974d719a0972b08cea0f17>:0
     
  8. Your problem is from this plugin ImageLibrary
    If you could also upload kits.json from data folder and kits.json file from config folder
    Need you to upload kits.json from data folder and kits.json file from config folder
     
  9. Sorry about that Resistance, I should have included this sooner. Thank you for looking at this for me, I really apprecaite you, good sir!
     

    Attached Files:

  10. upload this to your config folder and please just take the time reading the overview so mistakes dont happen like this. You can also read this post of mine your problem was the part at the bottom of the post about the config
     

    Attached Files:

  11. Does not work, what am I missing?

    See I'm kit ready
    upload_2018-8-2_21-37-19.png

    See kit window is fine
    upload_2018-8-2_21-37-59.png

    Kit added
    upload_2018-8-2_21-39-6.png

    I press the "add kit" button on the UI and select my "starter" kit. Once I do this, I lose my buttons on the UI.

    Updated config
    upload_2018-8-2_21-39-54.png

    End result
    upload_2018-8-2_21-41-26.png
     

    Attached Files:

    Last edited by a moderator: Aug 3, 2018

  12. Yes, oxide.reload Kits
     
  13. unload plugin
    delete kits_data.json
    reload plugin
    type in game /kit see if that fixes it
    If not can help over skype but going to bed soon so if it does not work can help when I am back
     
  14. Hey, its possible to add a featuer for block a kit by name for x houers after wipe?
     
  15. How do I add kits for events? Like chopper survival. I have them set up but everytime we spawn theres no classes..
     
  16. When i put items in my inv then do /kit add Test
    it adds it
    then when i do the kit and the gui and redeem it
    It says it redeems it but dosnt give any items
    idk what im doing wrong?
     
  17. Because you never done all commands needed see my post on page 366 its the last one on that page
     
  18. Yep that fixed it thank you!!!
     
  19. How can I edit the color and size of the kit names?