We've moved! Join us as we continue development on our new site at umod.org!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Thread Status:
Not open for further replies.
  1. Wulf

    Wulf Community Admin

    You still don't have to do it, it's entirely optional. The default path is in the server root, but if you want to use a different path you'd set the +oxide.directory as mentioned previously.
     
  2. but the plugins don't load?
     
  3. Wulf

    Wulf Community Admin

    If plugins aren't loading, you'd need to either move them to the new location or set the path to your old. They won't work if you don't have them in the right location.

    Your options:
    • use "oxide" folder where RustDedicated.exe is, move existing files if desired
    • set +oxide.directory "server/{server.identity}/oxide" and continue to use previous install location
    Both simple options, don't overthink it. ;)
     
  4. ok, what is the new location directory
     
  5. Wulf

    Wulf Community Admin

    The "oxide" folder in the root, where RustDedicated.exe is. Oxide will create it when you run the server.
     
  6. I put the command in my server but the plugins didn't load, here is my rust server setup commands:
    RustDedicated.exe -batchmode +server.ip 0.0.0.0 +rcon.ip 0.0.0.0 +server.port 28015 +rcon.port 28016 +rcon.password "***********" +server.maxplayers 500 +server.hostname "[US] Rusty Axe" +server.identity MechWarriorZero +server.description "Welcome to my server: [US] Rusty Axe" +oxide.dirctory"server/MechWarriorZero/oxide" +server.worldsize 4000 +server.seed 1782412474
     
  7. Wulf

    Wulf Community Admin

    You need a space after +oxide.directory.
     
  8. im putting the file in plugins folder (server - "test_oxide" - oxide - plugins) ... in output.txt i dnt fide errors :/
     
  9. Wulf

    Wulf Community Admin

    That'd be the wrong location since you aren't setting +oxide.directory; look the folder where RustDedicated.exe is, and look for "oxide" there.
     
  10. Then in the command-line i must add +oxide.directory ?
     
  11. Wulf

    Wulf Community Admin

    No, that is not needed if you use the oxide folder in the main directory.
     
  12. RustDedicated.exe is in "install path"
    Oxide is in "install path - server - test_oxide - oxide" and i add plugin in "install path - server - test_oxide - oxide - plugins"
    I add the command-line doesnt work anything T__T
     
  13. Wulf

    Wulf Community Admin

    That is not the correct location if your server is updated. Add your plugins to "install path - oxide - plugins", you don't need to set anything.
     
  14. But i havent an "oxide folder" in install path, but it is in "install path - server - test_oxide - oxide" ..... nothign i try to create an folder oxide in install path and nothing doesnt work
     
  15. Wulf

    Wulf Community Admin

    If you are fully updated with Oxide, actually running, and aren't setting +oxide.directory, then the folder would be there. I'd suggest making sure Oxide is actually running with the latest build first by checking the oxide.verison command when running the server.
     
  16. Now, I replace file oxide... but i dnt understand how to set server without problems ...
    > oxide.version
    Protocol: 1984.144.1
    Build Date: 05/06/2017 00:16:22
    Unity Version: 5.6.0f3
    Changeset: 20472
    Branch: main
    Oxide Version: 2.0.3263

    I started the example, and it works...
    [DOUBLEPOST=1494262010][/DOUBLEPOST]if i change command-line in .bat i'll change same command in file txt? (_start-example.bat / _start-example.txt)
     
  17. Wulf

    Wulf Community Admin

    Looks fine. Could you show me a screenshot of your server's directory where RustDedicated.exe is please? Also, what do you currently use exactly to start the server?
     
  18. direcotry: Imgur: The most awesome images on the Internet
    cmd server rp_rust_test: Imgur: The most awesome images on the Internet

    I think it's a good time ... lol :D

    ps now i see oxide folder in install path :D
    [DOUBLEPOST=1494262564][/DOUBLEPOST]workkkk plugin: Imgur: The most awesome images on the Internet
    [DOUBLEPOST=1494262677][/DOUBLEPOST]Sorry if I made you crazy and made you lose time. But know that I study gastronomic science, and the PC is a hobby and a passion all this fascinates me but I am n00b, with respect for them. :D
     
  19. I did that and still the plugins not loading? do I need to put +oxide.directory command at the front of the command?
     
Thread Status:
Not open for further replies.