Building Blocker

Fully prevents building in the building blocked zone. Fixes the "Devblog 158 of 4th may"

Total Downloads: 5,889 - First Release: May 4, 2017 - Last Update: Sep 29, 2017

5/5, 48 likes
  1. Hey, I'm finding your plugin extremely useful for my Rust balance overhaul project. I hope this doesn't come across as asking too much, considering that you're already offering your work for free, but is there a way you could only block twig foundations? I believe this is the best way to nerf the current meta without detracting from useful raid applications that it has.
  2. Check out this - BuildRevert.
  3. Thanl you!
  4. Great Plug in! Thanks Vlad-00003! Now back to the old Rust!
  5. Hello,

    If I use this plugin the tool cupboard well be like the old update.

  6. I don't quite get... Is this even a question? If it is - then answer is yes. This plugins purpose is to revert the changes made by facepunch.
  7. Hi , building block only worked broken. Mostly we cant build in cupboard blocked areas but tha only on one point i can place ledders or twig foundations. maybe its a bug. could u fix that pls? or give me a tip how to fix it :)

    best regards
  8. I don't get what you said. Can you explain it a bit more? Cos I don't really understand what happenes and what you should do.
  9. at first, sorry for my broken englich :)

    I installed the builfing blocker a few weeks ago. After that, it was not possible to place ladders or foundations in blocked areas as desired. After the last rust update somehow has to be a small bug in it. He still shows that it is blocked but in one place you can build anyway without permission.
    I hope this is something better to understand

    best regards
  10. That's strange. Can you make a video and pm it to me, so I can see what is going on. Cos I was unable to reproduce it myself.
  11. dose anyone else have a problem with this plugin interfering with no escape?

    players are able to tp home and to other players in building blocked zones and raid blocked zones.
    i know it shouldnt effect raid blocked but some reason since i updated it seems to have ..
  12. oh ye, NoEscape. Gonnna contact it's dev.
  13. is it doing it for you then aswell i guess?
  14. He shold add compability with my plugin on his side. I can't do anything about it.
  15. JMJ


    After todays update, my players are being kicked when placing a vending machine within their build range. Places fine outside of range. Here is what rcon is giving me..

    NullReferenceException: Object reference not set to an instance of an object Socket_Base.CheckSocketMods (.Placement placement) Construction.UpdatePlacement (UnityEngine.Transform transform, .Construction common, .Target& target) Planner+Guide.Update (.Target& placement, .Construction currentComponent) Planner.UpdateGuide () Planner.OnFrame () BasePlayer.HeldEntityFrame () BasePlayer.ClientUpdateLocalPlayer () BasePlayer.ClientCycle (Single deltaTime) Client.Update ()
    Last edited by a moderator: Jun 2, 2017
  16. How this can be related with my plugin?
    Are you sure that this is caused by building blocker? Did you tried to disable it for a test?
  17. JMJ


    Yes, they place fine when the mod is off. Its an odd error as it doesnt reference the problem plugin. I thought it was player specific at first but numerous players were able to recreate the error.
  18. my fault ignor
    Last edited by a moderator: Jun 2, 2017
  19. I don't get the problem. As I said before - I'm unable to reproduce it myself, so I still need some more information. Are you sure that there is no conflict between plugins? May be something like NoEscape? Untill @Calytic will add support for my plugin there is nothing can be done with this.
  20. i dont use no escape as i ran into problems with other plugins i just redownloaded a fresh copy and its working now