1. @UltimateByte
    Hey I also have an idea for a small update. Today our rcon tool seems to have crashed. I think it would be cool if I could restart the rcon tool without restarting the whole game server and it would be awesome if it's directly integrated with lgsm! Is it even possible to start rcon only?
  2. Nope. So your idea is not possible.

    @buelldm from what your saying, your install seems messed up.
  3. "[email protected]:~$ ./rustserver start
    ./rustserver: line 39: server.hostname: command not found
    ./rustserver: line 42: crafting.instant: command not found
    ./rustserver: line 43: server.headerimage: command not found
    ./rustserver: line 44: server.url: command not found
    ./rustserver: line 45: server.level: command not found
    [ FAIL ] Starting rust-server: Ownership issues found
    Information! The current user (rust2) does not have ownership of the following f iles:
    /home/rust2/lgsm/functions/check_permissions.sh: line 43: column: command not fo und

    Information! please see FAQ · GameServerManagers/LinuxGSM Wiki · GitHub -fail--starting-game-server-ownership-issues-found"

    Any fix? I made the file executable with "chmod +x check_permissions", still not working.
  4. How i can set Barren map? If set level="Barren" and +server.level${server.level} in command line, its doesnt work....
  5. [email protected]:~$ ./rustserver start
    [ .... ] Starting rust-server: NeoRust Survivors|Wiped 16.03|Home, tpr, custom loot, VIP|x3find: `/home/rust/serverfiles': Permission denied
    /home/rust/lgsm/functions/info_distro.sh: /usr/bin/lsb_release: /usr/bin/python3: bad interpreter: No such file or directory
    /home/rust/lgsm/functions/info_distro.sh: /usr/bin/lsb_release: /usr/bin/python3: bad interpreter: No such file or directory
    /home/rust/lgsm/functions/info_distro.sh: /usr/bin/lsb_release: /usr/bin/python3: bad interpreter: No such file or directory
    [ OK ] Starting rust-server: NeoRust Survivors|Wiped 16.03|Home, tpr, custom loot, VIP|x3
  6. any ideas about how can we use Barren maps on LGSM?
  7. Thank you so much!!! Everything works fine

    Can I ask?
    */30 * * * * su - rustserver -c '/home/rustserver/rustserver update' > /dev/null 2>&1
    this command already check oxidemods update?
    if not
    Will this command be correct? :
    30 6 * * * su - rustserver -c '/home/rustserver/rustserver force-update' > /dev/null 2>&1; su - rustserver -c '/home/rustserver/rustserver mods-update' >
  8. Anyone else having issues whenever you restart the rust server instance that it takes FOREVER for it to come online, even though details say its online?

    It takes a good 20+ minute before I can log into the rust server (not the linux server itself, just rust) via rcon, or even the game.

    I just updated rust and oxide on the server, and it wasn't connectable for a good 20+ minutes. Where as my old Windows based server that I had over a gameservers.com was back online after a few minutes after update.

    This is a dedicated server - Dual Intel Xeon 5420, 16GB RAM, and a SSD running Centos 7.

    Any ideas on why this is happening?
  9. Wulf

    Wulf Community Admin

    The navmesh generation in Rust takes a good while.
  10. r22


    I have installed Rust through LGSM but looks like i need to move hosts and set up the server again, can someone let me know which files i need to transfer so i do not lose anything
  11. Today, after I entered the ./rustserver fu and ./rustserver uf commands
    The server does not see the oxide. When I enter the command ./rustserver v in the console, this is what happens Screenshot
  12. Hello.
    I need your help. There are 4 servers on the dedicated server. 3 of them work well, and 1 consumes a lot of resources. The fact is that this was not before. It began to happen recently.
    The fact that the jumps FPS, from 350 to 50 It is on this server
    Dedicated server:
    Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
    Cores : 8
    Cache : 8192KB
    4x 8192MB
    2 x 240 GB
    P9D-M Series

    Rust server:
    Gather x20


  13. Hey guys, I would like to mention that LGSM works very well with Devuan linux if you want to get the most out of your server and avoid systemd.
  14. So as i see i need zip updater? to do all the update stuff or am i wrong? because im always to late to update when i did add the zip-updater as what is described on github but when i try to add ziplink for the oxide, (clicked it myself page 505 error. Or is there something new what i missed?

    # Modded
    ## Server stopped
    #*/5 * * * * su - rustmodded -c '/home/rustmodded/rustserver monitor' > /dev/null 2>&1
    #30 6 * * * su - rustmodded -c '/home/rustmodded/zip-updater/zip-updater' > /dev/null 2>&1
    #0 0 * * 0 su - rustmodded -c '/home/rustmodded/rustserver uf' > /dev/null 2>&1
  15. Hi a have Err... oxide.reload PluginName Rusty:
    > oxide.reload HitIcon
    Running dependency trace for CSharpCompiler.x86_x64
    User running server may not have access to all service files
    Error while compiling: compiler v0.0.0.0 disconnected

    chmode good...
    Sanks for help, CentOS 7 x64
  16. Wulf

    Wulf Community Admin

    Permissions are not set properly. The dependency trace is done when Oxide tries to chmod for you but can't due to a missing dependency.
  17. Tell me how to fix please
    Checked chmod, everything seems to be OK!
  18. Wulf

    Wulf Community Admin

    If you'd like Oxide to chmod for you, you'd need to install the dependency that the oxide/logs would show as missing from the dependency trace, otherwise you'd need to make sure the compiler is executable under the user that is running the server.
  19. Sooo a have it
    Everything is executed chmod normal, before that everything worked
  20. The link to Linux oxide has 404'd