1. Not sure if that's the right place but...
    Garry announced Rust Server for Linux is back !
    Garry Newman on Twitter

    I'll test it soon, but would be great to have a Linux compilation now, as Rust is pretty much useless without Oxide ! <3


    EDIT :
    Full tutorial : Setting up a Rust server with Linux and LGSM | Oxide

    LGSM Script for easy server installation and management released here : rustserver: Rust |
    Updated link for Linux Oxide version: https://raw.githubusercontent.com/OxideMod/Snapshots/master/Oxide-Rust_Linux.zip

    LGSM General support : General Discussion :: Linux Game Server Managers

    LGSM Dev support and bug report : Issues · dgibbs64/linuxgsm · GitHub

    Known issues with Rust for Linux : [Rust] 2 addons causing tmux session close to fail · Issue #714 · dgibbs64/linuxgsm · GitHub
     
    Last edited by a moderator: May 1, 2016
  2. Wulf

    Wulf Community Admin

  3. Thanks Wulf.
    Sorry for being outdated, I didn't come here in a while, as I knew Oxide because of Rust Linux server that got discontinued.
    I'll switch to the other topic. :)
     
  4. Hello!
    Ive got linux dedicated server and ive been wonderin if I can run Rust Experimental server on linux (Ubuntu 14.0.4)
    I have tried downloading linux files through steamcmd... it downloads everything but i get there "errors" on terminal: Gyazo - 74d1f2e1ba32938a2e371c30822b0945.png

    I have tried wine but it gives same result.
    Thanks for help.
     
  5. Hello,

    What causes this error? Judging by log seems like server starts correctly and it's working but I cant join because I get this error while connecting. I installed EAC for Rust on Ubuntu and tried +server.secure false but that did nothing.
     
  6. Wulf

    Wulf Community Admin

    The Rust server for Linux is not fully working as far as I know, and will not connect to Steam.
     
  7. Oh, so there's nothing at all what I can do/try?
     
  8. Wulf

    Wulf Community Admin

    Not that I know of until the developers fix it.
     
  9. I have managed to get a linux build of RUST working WITHOUT the use of wine | ubuntu command:

    apt-get install libc6

    Will install the libs required for unity (most are generic with the steamcmd ia32libs etc and gcc.

    If a developer of the oxide mod would like me to give them a server to help/assist with the linux development of the oxide mod then i would be happy to provide one.

    Kind Regards

    Jack
    SimplyFrag.co.uk Owner
     
  10. Didn't notice that recon. Thanks for letting me know.

    For those here who are running server hosts running tcadmin 2 i have listed a template for the rust-linux build and the installation instructions on the game config files section.

    Also in relation to: "The Rust server for Linux is not fully working as far as I know, and will not connect to Steam."

    My server has been able to successfully connect if thats any help to you wulf.
     
  11. That was the case until yesterday. However we did just replace some libraries to make it connect to steam.
    They are now included in the latest patch.
     
  12. Will you have a virtual machine running the rust on? Or you can use FULL hardware specifications?
     
  13. How is this solved? I don't see a solution posted.

    Steps I've taken:

    1. mkdir oxide
    2. cd ~/oxide
    3. mkdir steamcmd
    4. cd steamcmd
    5. download and unzip steamcmd
    6. run steamcmd
    7. force_install_dir /home/xxxxx/oxide
    8. app_update 258550 [validate]
    9. exit steamcmd
    10. cd ~/oxide
    11. ./RustDedicated -batchmode

    At that point I get precisely the same string of text, yet it never brings up the last line that would allow me to re-run it. I have to restart my ssh client and start over.

    Could anyone possibly do a walkthrough of a working linux server or at least show me what I'm possibly doing wrong/may have skipped etc?

    Is it running and I just can't see RCON maybe?
     
  14. There is no console in the linux version.
     
  15. Ahhh. okay. So it does appear to be running when i look at glances.

    Thank you.
     
  16. So, as i said earlier, and as some of you already noticed, Garry has announced Rust for Linux to be back and "working out of the box" !
    Garry Newman on Twitter

    I'll try that, and if it works, add support to this game to LGSM.
    More info about LGSM here : Home · dgibbs64/linuxgsm Wiki · GitHub
    For the record, i already added Hurtworld that uses the same engine, so the adaptation shouldn't be very hard.

    I'm so glad to see that there are still some Oxide builds for Linux !
    + There are updated links ! Which means Oxide may be the first game we actually support with LGSM "out of the box" with a command like ./rustserver oxide (or install-oxide, we're gonna have to see). And Hurtworld/7DTD (supported by LGSM too) may benefit from this as well.

    I've been waiting for so long to be able to make proper Rust Linux servers (wine is better to drink). I'm so happy guys, i thought it would be good to share some happiness, it may give some freshness after seeing too many lines of code. I've been very angry against Facepunch team though, but i'm happy it's back. Hopefully it's for good, and hopefully there will be a console now (or one day at least). Got some stuff to finish working on, then i'll try making a manual Linux Rust server right away ! Cheers everyone !

    One more thing : If Linux Oxide's builds are stable, would be nice to show your native support for Linux on game pages ! Currently it says "Compatibility :Wine for Linux (1.7.30+)" !
     
  17. I just did a fresh install of ubuntu 14.04. Do I need to do any additional sudo apt-get install?
     
  18. I advise you to use LGSM rustserver: Rust |
    + Required dependencies (and some for LGSM) are indicated on that website.
    For ubuntu x64
    lib32gcc1 libstdc++6 libstdc++6:i386
     
  19. So I tried the to get the missing dependency (libstdc++6:i386 mailutils postfix), but following the instructions I still had trouble:
    Code:
    [email protected]:~$ sudo dpkg --add-architecture i386
    [sudo] password for steam:
    [email protected]:~$ sudo apt-get install libstdc++6:i386 mailutils postfix
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
      gcc-4.8-base:i386 gcc-4.9-base:i386 guile-2.0-libs libc6:i386 libgcc1:i386
      libgsasl7 libkyotocabinet16 liblzo2-2 libmailutils4 libmysqlclient18
      libntlm0 libunistring0 mailutils-common mysql-common ssl-cert
    Suggested packages:
      glibc-doc:i386 locales:i386 mailutils-mh mailutils-doc procmail
      postfix-mysql postfix-pgsql postfix-ldap postfix-pcre sasl2-bin
      dovecot-common postfix-cdb postfix-doc openssl-blacklist
    The following NEW packages will be installed:
      gcc-4.8-base:i386 gcc-4.9-base:i386 guile-2.0-libs libc6:i386 libgcc1:i386
      libgsasl7 libkyotocabinet16 liblzo2-2 libmailutils4 libmysqlclient18
      libntlm0 libstdc++6:i386 libunistring0 mailutils mailutils-common
      mysql-common postfix ssl-cert
    0 upgraded, 18 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3,994 kB/9,785 kB of archives.
    After this operation, 37.9 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Err http://mirrors.digitalocean.com/ubuntu/ trusty-updates/main libc6 i386 2.19-0ubuntu6.6
      404  Not Found [IP: 198.199.99.226 80]
    Err http://security.ubuntu.com/ubuntu/ trusty-security/main libc6 i386 2.19-0ubuntu6.6
      404  Not Found [IP: 91.189.92.200 80]
    E: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/e/eglibc/libc6_2.19-0ubuntu6.6_i386.deb  404  Not Found [IP: 91.189.92.200 80]E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?