1. Wombat

    Wombat Shack Builder

    what host are you with
     
  2. Resistance

    Resistance Grenade Master

    Talk to you host support
     
  3. Wombat

    Wombat Shack Builder

    ive tryed there uk bases and all in bed ive think ive found which dll is the cause its the assembly-sharp.dll
     
  4. WizzyDizzzy

    WizzyDizzzy Naked Wanderer

    Server starts up fine as vanilla, once I install Install Oxide 2 20150605 server will not load. Any ideas?
    these are installed plugins:
    adminradar,copypaste,godmode,handyman,helivote,helptext,hiticon,itemskinrandomizer,kits,nightlanterns,qwquicksmelt,raidtracker,spawnconfig,stacksizecontroller,twigsdecay,vanish and zlevelsremastered
     
  5. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Check your logs for errors.
     
  6. WizzyDizzzy

    WizzyDizzzy Naked Wanderer

    Got this: [Error] Failed to load plugin '1', Does that"1" represent ffirst plugin alphabetically?
    --- Double Post Merged, Sep 29, 2017 ---
    it also stated this, seems they loaded correctly: 18:02 [Info] AdminRadar, CopyPaste, Godmode, HandyMan, HeliVote, HelpText, HitIcon, ItemSkinRandomizer, Kits, NightLantern, QuickSmelt, RaidTracker, SpawnConfig, StackSizeController, TwigsDecay, Vanish and ZLevelsRemastered were compiled successfully in 3578ms
     
  7. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    No, the first error means you are using -load in your startup script and can be removed. If plugins are loading, sounds like it is working.
     
  8. WizzyDizzzy

    WizzyDizzzy Naked Wanderer

    Hmm I'll keep searching for the issue. Thanks Wulf. very responsive to the post as usual. Do you ever sleep bro? Over my last year of owning a server I've had roughly 3 or 4 questions and I'm pretty sure you responded within 5 minutes every time. Thank you again!
     
  9. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Are you seeing anything else in the logs? Does anything work?
     
  10. WizzyDizzzy

    WizzyDizzzy Naked Wanderer

    After 5 or 6 server update and oxide reinstalls, below are my last two. I decided to remove Spawnconfig due to the [warning] and it worked.

    Thanks Wulf, I'm a pleb and didn't know about the "logs" I'll definitely use this in the future.
    Code (Text):
    18:02 [Info] Loading Oxide Core v2.0.3508...
    18:02 [Info] Loading extensions...
    18:02 [Info] Downloading CSharpCompiler.exe for .cs (C#) plugin compilation
    18:02 [Info] Download of CSharpCompiler.exe completed successfully
    18:02 [Info] Loaded extension CSharp v2.0.3508 by Oxide Team
    18:02 [Info] Loaded extension JavaScript v2.0.3270 by Oxide Team
    18:02 [Info] Loaded extension MySql v2.0.3508 by Oxide Team
    18:02 [Info] Loaded extension Python v2.0.3171 by Oxide Team
    18:02 [Info] Loaded extension SQLite v2.0.3508 by Oxide Team
    18:02 [Info] Loaded extension Unity v2.0.3508 by Oxide Team
    18:02 [Info] Loaded extension Rust v2.0.3508 by Oxide Team
    18:02 [Info] Using Covalence provider for game 'Rust'
    18:02 [Info] Loading plugins...
    18:02 [Info] AdminRadar, CopyPaste, Godmode, HandyMan, HeliVote, HelpText, HitIcon, ItemSkinRandomizer, Kits, NightLantern, QuickSmelt, RaidTracker, SpawnConfig, StackSizeController, TwigsDecay, Vanish and ZLevelsRemastered were compiled successfully in 3578ms
    18:02 [Info] [TwigsDecay] TwigsDecay: Default decay has been disabled
    18:02 [Error] Failed to load plugin '1' (no source found)
    18:02 [Error] Failed to load plugin '1' (no source found)
    18:03 [Info] [SpawnConfig] Loaded 32 SpawnPopulations and 193 SpawnGroups.
    18:11 [Warning] Calling 'OnTerrainInitialized' on 'SpawnConfig v1.0.14' took 500467ms [GARBAGE COLLECT]
    18:11 [Warning] Calling 'OnTerrainInitialized' on 'SpawnConfig v1.0.14' took average 0ms [GARBAGE COLLECT]
    18:34 [Info] Loading Oxide Core v2.0.3508...
    18:34 [Info] Loading extensions...
    18:34 [Info] Downloading CSharpCompiler.exe for .cs (C#) plugin compilation
    18:34 [Info] Download of CSharpCompiler.exe completed successfully
    18:34 [Info] Loaded extension CSharp v2.0.3508 by Oxide Team
    18:34 [Info] Loaded extension JavaScript v2.0.3270 by Oxide Team
    18:34 [Info] Loaded extension MySql v2.0.3508 by Oxide Team
    18:34 [Info] Loaded extension Python v2.0.3171 by Oxide Team
    18:34 [Info] Loaded extension SQLite v2.0.3508 by Oxide Team
    18:34 [Info] Loaded extension Unity v2.0.3508 by Oxide Team
    18:34 [Info] Loaded extension Rust v2.0.3508 by Oxide Team
    18:34 [Info] Using Covalence provider for game 'Rust'
    18:34 [Info] Loading plugins...
    18:34 [Info] AdminRadar, CopyPaste, Godmode, HandyMan, HeliVote, HelpText, HitIcon, ItemSkinRandomizer, Kits, NightLantern, QuickSmelt, RaidTracker, StackSizeController, TwigsDecay, Vanish and ZLevelsRemastered were compiled successfully in 3516ms
    18:34 [Info] [TwigsDecay] TwigsDecay: Default decay has been disabled
    18:34 [Error] Failed to load plugin '1' (no source found)
    18:34 [Error] Failed to load plugin '1' (no source found)
    18:36 [Info] [AdminRadar] Took 99.0093ms to cache 1796/26739 entities
    18:36 [Info] [Item Skin Randomizer] Loaded 857 approved workshop skins.
     
    Last edited by a moderator: Sep 29, 2017
  11. Krazy J

    Krazy J Shack Builder

    I'm working with support from my gamehost, trying to get the update for oxide to install wont work at all or at all correctly. It broke the server after updating to the latest patch, It wont start now whether it is installed or not now. fyi.. They are having a problem with installing oxide also.

    Not sure where the issue lies at this point.
     
  12. Wombat

    Wombat Shack Builder

    this is what i get when trying also i can run the server as vanilla but not with oxide
     
  13. Krazy J

    Krazy J Shack Builder

    vanilla doesn't even run on mine. I'm sure I'll have to reinstall. Something is wrong for sure.
     
  14. Corporal

    Corporal Naked Wanderer

    There is no report of oxide in a folder \RustDedicated_Data\output_log.txt ?
     
  15. Bambalotta

    Bambalotta Scavenger

    Hey Wulf sorry for putting it here but I cant find any way to contact someone about the rust oxide download. Its missing the compiler files. Can you check that out please?
     
  16. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The compiler is downloaded automatically. See the Latest Announcement for links on where to manually download it if needed.

    If you see no references to Oxide in your logs, then Oxide is not installed.
     
  17. Bambalotta

    Bambalotta Scavenger

    Thanks for the quick reply as always!
     
  18. Corporal

    Corporal Naked Wanderer

    It is worth it.So I ask)
     
  19. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Ask what?
     
  20. Corporal

    Corporal Naked Wanderer

    Oxide is on the server.And the file is not