1. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    Hi! i try to upload map on steam... done, anyway serwer report some problems:

    The AssetBundle 'C:\TCAFiles\Users\KrystianA\8057\steamapps\workshop\content\393420\814651982\814651982.win64.map' can't be loaded because it was not built with the right version or build target.

    (Filename: Line: 358)

    Scene 'kosa1' (-1) couldn't be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
    To add a scene to the build settings use the menu File->Build Settings...

    (Filename: Line: 520)

    Level root not assigned by map, ensure you have LevelRootRegister in the root of the map. Quitting
    END
    add scene? how? mac windows and linux generated. please help me im so confuse :(
     
  2. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    Anyone know how to fix that f... s...!!!! im not sleep from 2 f... days?!?!?!?!
    log from serwer:

    Starting Game. Save Version: 0.3.8.1 Protocol Version: 45 Send Buffer Size: 131071
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Platform assembly: F:\steam\steamapps\common\Hurtworld Dedicated Server\Hurtworld_Data\Managed\Mono.Security.dll (this message is harmless)
    Platform assembly: F:\steam\steamapps\common\Hurtworld Dedicated Server\Hurtworld_Data\Managed\System.Configuration.dll (this message is harmless)
    Platform assembly: F:\steam\steamapps\common\Hurtworld Dedicated Server\Hurtworld_Data\Managed\System.Xml.dll (this message is harmless)
    > servername Unconfigured

    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    > host 12871 pandora

    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Steam GameServer initialized
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded mod at F:/steam/steamapps/common/Hurtworld Dedicated Server/Hurtworld_Data\sharedenv\sharedenvironment.win64.bundle
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded mod at F:/steam/steamapps/common/Hurtworld Dedicated Server/Hurtworld_Data\sharedenv\shaderpack.win64.bundle
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded config Default Construction Pack (28)
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded mod at F:/steam/steamapps/common/Hurtworld Dedicated Server/Hurtworld_Data\mods\construction_defaultpack.win64.mod
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded config Default Vehicle Pack (175)
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Loaded mod at F:/steam/steamapps/common/Hurtworld Dedicated Server/Hurtworld_Data\mods\vehicles_defaultpack.win64.mod
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    SteamServerConnected
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    12/10/2016 7:40:52 PM [EAC] [Info] [SetLogCallback] Procedure: 0000000013D44E90 LogLevel: Debug
    12/10/2016 7:40:52 PM [EAC] [Info] [SetServer] Name: client
    12/10/2016 7:40:52 PM [EAC] [Debug] [Cerberus] network: Release, maxBufferSize: 32768, maxBufferCount: 512
    .
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    .
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    .
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    .
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    .
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    The AssetBundle 'F:/steam/steamapps/common/Hurtworld Dedicated Server/Hurtworld_Data\maps\pandora.win64.map' can't be loaded because it was not built with the right version or build target.
    (Filename: Line: 358)

    Scene 'pandora' (-1) couldn't be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
    To add a scene to the build settings use the menu File->Build Settings...
    (Filename: Line: 520)

    Level root not assigned by map, ensure you have LevelRootRegister in the root of the map. Quitting
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Exception when loading navmesh Object reference not set to an instance of an object at RuntimeAssetManager.LoadNavmesh () [0x00000] in <filename unknown>:0
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    No navmesh loaded, creatures won't be able to move.
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Abort running Threads: 1
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Unloaded all mods
    (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Setting up 1 worker threads for Enlighten.
    Thread -> id: 18ec -> priority: 1

    i was generate map 2000 times change name of project any other ideas?
    --- Double Post Merged, Dec 10, 2016 ---
    Than you for moving my post anyway i will be more happy to get an answer :) HEEELP! im nooob! :...(
     
  3. ZTIF

    ZTIF Scavenger

    Did you attach the LevelRootRegister script to LevelObjects in the hierarchy? Are you using the correct version of Unity? Are you following the SDK youtube tutorials?
     
  4. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    on the first question: no, not yest i miss that, omg....
    on the second i use new wersion unity 5.5.0f3
    on the third. that tutorials watching many times step by step , and again step by step mto figureout what mistake i was made, can you send me correct version unity. Thank you my friend ! im waiting to answer!!
    --- Double Post Merged, Dec 11, 2016 ---
    now i remember that was start after unity update from version 5.4.1f1, because i forgot instal linux and mac components ;)
    --- Double Post Merged, Dec 11, 2016 ---
    sorry levelroot is on the place, but it schould cover all map??
     
  5. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    There is no AstarPath object in the scene, serwer restarting after few minutes. do it mean i must delete old version of map and rebuild it again?
    --- Double Post Merged, Dec 11, 2016 ---
    ZTIF you have right! new wersion doesnt work properly thanks alot now i have another problem with AstarPath i was use tool to check assets found two rocks and that all. omg that editor blow my mind!!
     
  6. ZTIF

    ZTIF Scavenger

    AstarPath is what they use for making a navmesh. So far I've not seen anyone being able to actually bake a navmesh and have working ai though.. Seems to be a forgotten issue for them - or they are planning a rebuild of the pathfinding for animals. I've never had that error though, so I'm afraid I have no idea why you're getting it or how to fix it.
    ..Except look at the videos where Spencer is making a navmesh and try to follow the same steps to the point.
     
  7. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    Now i know that reinstall of unity was breaking scripts on my map i make new mob spawner and will see. Thank you my friend!
     
  8. [PRL]Kosa

    [PRL]Kosa Naked Wanderer

    new error what now?

    eac_server.so [x64] :: OnLoad()
    13/12/2016 16:31:57 [EAC] [Info] [SetLogCallback] Procedure: 0x41d3aeb0 LogLevel: Debug
    13/12/2016 16:31:57 [EAC] [Info] [SetServer] Name: client
    13/12/2016 16:31:57 [EAC] [Debug] [Cerberus] network: Release, maxBufferSize: 32768, maxBufferCount: 512
    Server failed to start: Exception0: Failed to bind to port range 12891-12891 ---> System.Net.Sockets.SocketException: Address already in use
    at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) [0x00000] in <filename unknown>:0
    at uLink.NetworkSocket+UDPIPv4Only.Bind (NetworkEndPoint listenEndPoint) [0x00000] in <filename unknown>:0
    at Class52.method_17 () [0x00000] in <filename unknown>:0
    --- End of inner exception stack trace ---
    at Class52.method_17 () [0x00000] in <filename unknown>:0
    at Class62.method_278 (Int32 int_11, Int32 int_12, Int32 int_13) [0x00000] in <filename unknown>:0

    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 37)

    Closing network connections...

    wrong ports on serwer?