1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

UpdateChecker

Automatic update checking and notifications for plugins

Total Downloads: 20,648 - First Release: Oct 24, 2014 - Last Update: Feb 1, 2018

5/5, 48 likes
  1. t-wez

    t-wez Scavenger

    I don't seem to be having this issue on my end. Works fine for me
     
  2. NavyChief

    NavyChief Shack Builder

    Still getting it:

    Code (Text):
    (23:01:03) | Web request callback raised an exception (NullReferenceException: Object reference not set to an instance of an object)
      at Oxide.Plugins.Updater.NotifyOutdated (IPlayer player) [0x00000] in <filename unknown>:0
      at Oxide.Plugins.Updater+<CheckForUpdates>c__AnonStorey1.<>m__0 (Int32 code, System.String response) [0x00000] in <filename unknown>:0
      at Oxide.Core.Libraries.WebRequests+WebRequest.<OnComplete>b__42_0 () [0x00000] in <filename unknown>:0
     
  3. tomhud

    tomhud Shack Builder

    no issues here with this plugin - works as intended.
    U tried removing it and adding a fresh copy back ?
     
  4. LaserHydra

    LaserHydra Plugin Developer

    Can you please send me a list of your plugins (if you prefer, per pm) and your Updater files (config & plugin)?
     
  5. tomhud

    tomhud Shack Builder

    is this working after yesterdays Update as all plugins are showing cant get latest version.
    Was fine yesterday.

    [Updater] Couldn't get the latest version of plugin RemoverTool
    [Updater] Couldn't get the latest version of plugin Updater
    [Updater] Couldn't get the latest version of plugin SkipNightUI
    [Updater] Couldn't get the latest version of plugin ServerRewards
     
    t-wez likes this.
  6. Stew 2

    Stew 2 Naked Wanderer

    copy on that issue... having the same....
     
    t-wez likes this.
  7. VikingNor

    VikingNor Naked Wanderer

    I have the same issue
     
    t-wez likes this.
  8. JTN1992

    JTN1992 Naked Wanderer

    Same issue here too
     
    t-wez likes this.
  9. Hider

    Hider Wood Hoarder

    fix that
     
    t-wez likes this.
  10. ClumsyZombie

    ClumsyZombie Wood Hoarder

    Yup I am having same issue on all my servers.
     
    t-wez likes this.
  11. GonzoTheThird

    GonzoTheThird Scavenger

    Same problem
     
    t-wez likes this.
  12. diXon2

    diXon2 Naked Wanderer

    The same Here...
     
    t-wez likes this.
  13. Yanisin

    Yanisin Naked Wanderer

    Same problem
     
    t-wez likes this.
  14. tomhud

    tomhud Shack Builder

    i think all updaters are broke - hope they do get fixed though as hate having to do them manually.
     
    t-wez likes this.
  15. Reaper_fuze

    Reaper_fuze Naked Wanderer

    Hi, just need to know, I am using this plug-in and I am getting the message "couldn't get the latest version of plugin " the plugin then lists all the plugins in the server as unable to get latest version, could you help?
     
  16. tomhud

    tomhud Shack Builder

    we need to wait for an update im afraid.Everyone is getting the same error at the moment.
     
    Tunnleram likes this.
  17. LaserHydra

    LaserHydra Plugin Developer

    I noticed the issues, this seems to be caused by the SSL update to the site. It looks like the webrequests sent can not work with ssl.
     
    ClumsyZombie, Tunnleram and tomhud like this.
  18. mspeedie

    mspeedie Plugin Developer

    I have been trying to hack this to work.

    Initially I just changed this line to add the "S":
    webrequest.EnqueueGet($"https://oxidemod.org/plugins/{plugin.ResourceId}/", (code, response) =>

    But the calls still failed with:
    [Updater] Error getting response stream (Write: The authentication or decryption has failed.): SendFailure

    I assumed either the certificate need a looking into or that access needs to get fixes so we can add SSL support. But then I found this:
    https://forum.unity.com/threads/unity-2017-1-tls-1-2-still-not-working-with-net-4-6.487415/

    If I am reading that correctly, for right now it seems this will not work until either Unity fixes their code, or Oxide allows non-SSL access to the site again. Simplest fix is allowing non-SSL access to oxidemod as a Unity fix could be a long while as this was identified as an issue over a year ago. I could be off on a tangent here. I am keen to get this working as maintaining plugins manually is labour intensive.
     
    Last edited: Jan 14, 2018
  19. tomhud

    tomhud Shack Builder

    yeah it stopped working when this site updated.
     
  20. Psystec

    Psystec Plugin Developer

    It would be nice if there is an ignore list included with the next update :)