1. @Infinitypl

    For LXC Ubuntu 14.04.3 (quickly, to be improved) :
    sudo su
    apt-get update
    apt-get upgrade -y
    mkdir /opt/rust
    echo "deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main" > /etc/apt/sources.list.d/wine.list
    dpkg --add-architecture i386
    apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5A9A06AEF9CB8DB0
    apt-get update
    apt-get install -y --no-install-recommends wine1.7-amd64 lib32gcc1 xvfb xauth libdbus-1-3
    mkdir /opt/steamcmd
    cd /opt/steamcmd/
    apt-get install -y byobu wget nano
    wget $STEAMCMD_URL
    tar -xzf steamcmd*.tar.gz
    /opt/steamcmd/steamcmd.sh +@sSteamCmdForcePlatformType windows +login anonymous +force_install_dir /opt/rust +app_update 258550 -beta experimental validate +quit
    cd /opt/rust/
    xvfb-run --auto-servernum --server-args='-screen 0 640x480x24:32' wine64 RustDedicated.exe -batchmode +server.hostname "SERVER NAME" +server.port 28015 +server.identity "rustserver" +server.maxplayers 250 +rcon.port 28016 +rcon.password "RCON_PASSWORD" +rcon.ip -logFile "/opt/rust/out.txt"
    Install Oxide after...
  2. @CestPasFaux is it for ubuntu 14.04 server? Not the desktop one?
    [DOUBLEPOST=1451776736,1451749283][/DOUBLEPOST]@AndrejP do you still have the same problem?
  3. Hello Infinitypl
    Today I have make the same procedure again as I posted before. I make it on fresh installed Ubuntu desktop 14.04, wine 1.8, winetricks, wine-gecko and now it works. Rust server running, can connect to it, and .cs plugins are now loading correctly. But still remains disconnecting problem that I described in my post.
  4. I'm running Debian 8 server and after lots of problems i got Wine installed but now i just hit a road bump more..

    @digfordiamonds:/home/steam/rust# WINEARCH=win64 WINEPREFIX=~/.wine64 wine RustDedicated.exe -batchmode -load
    fixme:heap:RtlSetHeapInformation 0x1800000 0 0x16efdb0 4 stub
    fixme:system:SetProcessDPIAware stub!
    fixme:heap:RtlSetHeapInformation 0x3380000 0 0x16ef240 4 stub
    Mono path[0] = 'Z:/home/steam/rust/RustDedicated_Data/Managed'
    Mono path[1] = 'Z:/home/steam/rust/RustDedicated_Data/Mono'
    Mono config path = 'Z:/home/steam/rust/RustDedicated_Data/Mono/etc'
    fixme:win:EnumDisplayDevicesW ((null),0,0x16ef2e0,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),1,0x16ef2e0,0x00000000), stub!
    err:winediag:nulldrv_CreateWindow Application tried to create a window, but no driver could be loaded.
    err:winediag:nulldrv_CreateWindow Make sure that your X server is running and that $DISPLAY is set correctly.

    Any know of a fix?
  5. Wulf

    Wulf Community Admin

    Pretty sure the server needs a graphics card.
  6. Guys, can i run rust LEGACY server on ubuntu? Im a trying, but this not started.
  7. I wish Garry and his team would go ahead and make a dedicated server build for Linux. But until then..... I guess we'll suffer with wine.
  8. Wulf

    Wulf Community Admin

    They do have a Linux build, though I haven't tried it myself.
  9. So, I have done everything, server is UP but I can't see "normal console" like on windows. I mean I see only bunch of shit instead of server console. Anyone had something like this?

  10. It does not start. We tried all distributions
  11. Where did you get linux files? May I have them?
  12. steamcmd.sh +login anonymous +force_install_dir "rust_linux" +app_update 258550 validate +quit
  13. ??? Its working since when?? And, is it really working? @Wulf, oxide work with that??
  14. Wulf

    Wulf Community Admin

  15. Jeez... Why this post exist if there are a linux version?? <3
  16. ./RustDedicated -batchmode -nographics -logfile log.txt


    Got a SIGSEGV while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.
  17. Wulf

    Wulf Community Admin

    This thread was made half a year before a Linux version existed.
  18. Ohh... @Wulf, you are talking of a Linux version for the old Rust, no?
    Or you mean than experimental works on linux? Oo