We've moved! Join us as we continue development on our new site at umod.org!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Thread Status:
Not open for further replies.
  1. Wulf

    Wulf Community Admin

    Some of you may have noticed that we changed commands for Oxide's core a bit the other day, though I suspect most of you haven't updated your servers yet so may not have; so hopefully you see this announcement instead of posting a new thread!

    When I originally added the non-prefixed (ie. reload, load, grant, etc. without oxide.) commands, I was hoping that there wouldn't be any issues as it's always nice to have shorter commands that are easy to remember and quick to use. However, we've noticed over the past that there have been an increasing amount of game commands that share the same name as Oxide's non-prefixed commands, so we've decided that it'd be best to remove those to avoid conflicts and the hopefully stop the questions of "why doesn't show work in Rust?", "my Reign of Kings group command got replaced!", or "what is this "Failed to load '1' in my log?"

    Now, I probably shouldn't have added the non-prefixed commands anyway as prefixes are generally the best way to add commands to a game to avoid conflicts. The change isn't major though, and is a quick replacement if you're using any of the non-prefixed commands.

    The original "oxide." prefixed commands are still there, but we've also added additional prefixes o, perm, and plugin depending on the command. The o prefixed commands are a short alternative and the perm and plugin are for the permission and plugin commands respectively.

    If you would like to keep using shorter commands or create any number of custom commands or command aliases, you can use a plugin such as CustomChatCommands | Oxide.

    I apologize for any inconvenience this may have caused. There will be more breakage down the road as development progresses (can't hold on to everything forever), mainly with some older API and library helpers getting removed in favor of newer API and some things renamed. We're also working on moving all plugins over to a GitHub repository for easier maintenance, contribution, and to keep up with them. Any abandoned or unmaintained plugins that haven't already been replaced with universal versions will also be updated as someone is able, it'll just take a bit of a time.

    The changes:
    • Removed generic commands to avoid conflicts with games (ie. load, reload, grant)
      The non-prefixed commands removed conflicted with some game commands, so additional aliases were added to avoid confusion and make them more unique. The oxide.* prefixed commands still remain (ex. oxide.reload)
    • Added o.* prefixed commands as a short variant to oxide.* commands (ex. o.reload, perm.grant, etc.)
    • Added plugin.* and perm.* as prefixes to plugin and permission commands (ex. plugin.unload, perm.revoke, etc.)
     
    Yari, Nick!, JCfromTB and 2 others like this.
  2. Not your fault if owners didn't do update ;)

    For me, I just added alias to oxide.command and works fine ^^'

    Have you a date for GitHub repository ? Looks good !
     
    Thabe likes this.
  3. I need help because I can not use the commands to add the groups and give the appropriate permissions for each one.
     
  4. Last week I was able to use oxide.command grant user whoever permission. This doesnt work now, what am I doing wrong?
     
  5. Wulf

    Wulf Community Admin

    oxide.command grant? oxide.grant is a command, not grant.
     
  6. Im trying to grant someone permission for a VIP kit. I used to use "grant user name permission" but that doesnt work now.
     
  7. Wulf

    Wulf Community Admin

    Did you read the first post of this thread?
     
    PPlank, GREEN_BIRD and Windamyre like this.
  8. Yes. Im spazzy right now... I figured it out. Sorry dude.
     
    Windamyre likes this.
  9. I apologize in advance for my ignorance and something that is disturbing me a lot ... I can not in any way add that shit of permission on my server, am I doing something wrong? Thank you for understanding!
    bandicam 2017-10-26 23-48-28-068.jpg
     
  10. Wulf

    Wulf Community Admin

    Commands look fine, but I can't reproduce that issue.
     
  11. I understand ... However, there was an earlier version of the oxide that worked perfectly but you gave the issue of changing because there were conflicts with some things and thanks for the quick response.

    I'm really grateful for your work. sorry for anything

    As you can see I type the commands correctly and still does not execute and return the message as it should be.
     
  12. Wulf

    Wulf Community Admin

    The command haven't changed since this announcement, so I can't really say what's wrong. All I can suggest is restarting or updating Oxide again.
     
  13. I performed the update and rebooted and it did not work as expected ... on version 2.0.3520 the permissions commands worked and version 2.0.3528 onwards itself removed the generic commands to avoid conflicts however this affected the use of the same, those of being executed.
     
  14. Wulf

    Wulf Community Admin

    3520 and 3528 are pretty old builds.

    Edit: If you’re on Rust Legacy, try the latest snapshot from our AppVeyor.
     
    Last edited: Oct 27, 2017
Thread Status:
Not open for further replies.