1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. The tools provided in this section are provided by third-parties with no guarantees on quality or safeness. Please use good judgement and common sense when using them.

RustAdmin RCON Tool

Efficient RCON tool to manage your server and its players (written in C++)

Total Downloads: 23,282 - First Release: Sep 24, 2014 - Last Update: May 15, 2018

4.96825/5, 126 likes
  1. Watch dogs

    Watch dogs Naked Wanderer

    hey i'm having issue with my admin tool i downloaded latest oxide version but for some reason admin tool connects for few seconds then disconnects again all the time so we had to go back to this older version oxide Oxide 2.0.2582 for Rust 1069 can you please tell me how to fix this or something because newer version oxide has already connection fix this version we got Oxide 2.0.2582 for Rust 1069 don't have already connected fix in it. Maybe I installed Oxide wrong? Can someone tell me how to install it properly maybe or make a video, thanks.
     
  2. -={U.S.P}=- DOCTROS

    -={U.S.P}=- DOCTROS Wood Hoarder

    Hello All,

    Quick question, anytime I use the "Give to me" button or the "Give to" then select myself nothing happens. It was working just fine yesterday. I relogged back into the game, restarted RustAdmin still no go. I did also install the "Give.cs" plugin for a moderator on my server. Could there be a conflict with RustAdmin?

    Any info would help. Thanks!
     
  3. DEUSNEXUS

    DEUSNEXUS Plugin Developer

    Code (Text):
    NullReferenceException: Object reference not set to an instance of an object
      at Facepunch.Network.Raknet.Server.GetAveragePing (Network.Connection connection) [0x0000d] in <21b08aeac4904b598ca162bda2219efe>:0
      at ConVar.Admin.<playerlist>m__0 (BasePlayer x) [0x0005a] in <9f5b7a9ff0c44ff99aacb86ef56ae396>:0
      at (wrapper delegate-invoke) System.Func`2[BasePlayer,ConVar.Admin+PlayerInfo].invoke_TResult_T(BasePlayer)
      at System.Linq.Enumerable+SelectListIterator`2[TSource,TResult].ToArray () [0x00034] in <839a3cb835c04d14aeb58d83bb7bc4bd>:0
      at System.Linq.Enumerable.ToArray[TSource] (System.Collections.Generic.IEnumerable`1[T] source) [0x0001f] in <839a3cb835c04d14aeb58d83bb7bc4bd>:0
      at ConVar.Admin.playerlist () [0x00027] in <9f5b7a9ff0c44ff99aacb86ef56ae396>:0
      at ConsoleGen.<All>m__1B (ConsoleSystem+Arg arg) [0x00000] in <9f5b7a9ff0c44ff99aacb86ef56ae396>:0
      at ConsoleSystem.Internal (ConsoleSystem+Arg arg) [0x00064] in <1cfa5b0b65974a68bdd8f9282a37116b>:0
    UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    UnityEngine.Logger:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    ConsoleSystem:Internal(Arg)
    ConsoleSystem:Run(Option, String, Object[])
    Facepunch.RCon:OnCommand(Command)
    Facepunch.RCon:Update()
    ServerMgr:DoTick()
     
  4. Groomlake51

    Groomlake51 Naked Wanderer

    pls update the ban list there are peoples who banned from server with no resonse clan ban is not a hack i think you need more supporter Vfloyd
     
  5. Freaqminders

    Freaqminders Wood Hoarder

    are you connecting via "experimental" or "webRCON" ??
     
  6. Time Junkmen

    Time Junkmen Naked Wanderer

    Hello,when i use rustadmin to give me 10k wood ,it deosn't appear into the console log
     
  7. SlodderVos

    SlodderVos Naked Wanderer

    hi, i cant enable fps in the settings tab. does this not work anymore. or do i miss somthing?
     
  8. Freaqminders

    Freaqminders Wood Hoarder

    can't too... dont know why, i just live with it :D
     
  9. OldFart

    OldFart Naked Wanderer

    Anyone else unable to connect with Rust Admin after the last update?
     
  10. Mors4420

    Mors4420 Naked Wanderer

    I'm trying to use RustAdmin to give players a little food and a welcome message when they join the server, but it doesn't work. I get the message, but no items are given to me.

    The commands I'm using look like this.

    inventory.giveid -1252059217 1;say notification: Testing

    I've also tried it like this

    inventory.giveid "-1252059217" "1";say notification: Testing

    I see the message "Testing" but no items given. It is supposed to give to any player when they log in with a 24 hour cool down before triggering again.

    I have also tried the option using text in chat
    Usging: !helpme

    Same results, I enter in !helpme see the message pop up "Testing" but no item given.

    However, I can use the give tool to give players anything manually.
     
  11. pookins

    pookins Shack Builder

    Cannot "give" anything to anyone including myself, cannot tp anyone ,
     
  12. nl gamer 2

    nl gamer 2 Naked Wanderer

    i cant connect with my server what can i do i put my ip adres later 28015 and 28025 and my pasword but no connect pleas help i just pay for my server al lot
     
  13. PrimeVoidValkyrie

    PrimeVoidValkyrie Naked Wanderer

    Hey I downloaded the program, typed everything I've seen needed but the program will not connect. It shows Disconnect in red in the bottom corner. What can I do? I am also on a WebRcon.

    Edit: Got it!
     
    Last edited: Aug 17, 2018 at 3:41 PM