1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. The tools provided in this section are provided by third-parties with no guarantees on quality or safeness. Please use good judgement and common sense when using them.

RustAdmin RCON Tool

Efficient RCON tool to manage your server and its players (written in C++)

Total Downloads: 22,840 - First Release: Sep 24, 2014 - Last Update: May 15, 2018

4.96774/5, 124 likes
  1. RocK1

    RocK1 Naked Wanderer

    Hello, when a am restarting the software she server does not save? i have to write new commands everytime and it realy annoying!
    is there i fix for this?
     
  2. R0GU3 DUCKBUTT

    R0GU3 DUCKBUTT Naked Wanderer

    what command are you writing that is not saving? If it is a server command of any type (example. decay.scale 0), you need to then follow it with server.writecfg
     
  3. Resistance

    Resistance Grenade Master

    server.writecfg is not for plugins its only when a new mod or admin is made and saved in the users.cfg file
     
  4. wizoLulz

    wizoLulz Naked Wanderer

    So none knows how to get this working with betterchat? :eek:
     
  5. Resistance

    Resistance Grenade Master

    Many know and its been posted its up to you to find it
     
  6. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    From my previous posts:
    Code (Text):
    \[(Better\s)?Chat\]\s(?<sender>.*?):\s(?<message>.*)
     
  7. Shotgun Teddy

    Shotgun Teddy Wood Hoarder

    Two-part question:
    1) I have automated text my server says in chat when someone logs on and logsoff. These messages always start with "SERVER blah blah etc." It's ugly. Is there a way to have it so removes the "SERVER" portion and just posts the text I specified in chat?

    2) Has the original developer abandoned this project? He hasn't updated in 7 months, and many components/items are missing.
    --- Double Post Merged, Jan 26, 2018 ---
    Yeah I've had this issue a lot with RustAdmin. The only thing I can think of that I did to get it working was changing my server configuration and the RustAdmin configuration. I've found that sometimes it just breaks if you change some configuration later. I've installed it fresh and put in the configs and left it as so cause I've been afraid of it breaking.

    You could try changing the ports for RCON etc to the default (28015, 28016). If you haven't changed them from the default, try changing the ports to something else on your server and then changing them in RustAdmin and see if itll connect.

    Try saving your configuration and give it a name in RustAdmin and make sure that "auto-connect" and "reconnect if disconnected" are selected as well.

    Check the configurations within the RustAdmin folder itself, open it up in notepad, and see if the files configuration matches what you input in RustAdmin in the GUI.

    Another thing is to look through your logs, if you see any 'errors' post em here, I'm sure others are interested in seeing them, considering how many people are having the same issues.

    Another thing is to sift back on previous posts in this thread and see what others have done. Undoubtedly 95% of questions posted here have been answered at some point in this thread. I mean there are 176 pages (as of Jan, 26th 2018) so I know its a lot of shit to sift through but yeah.

    I gave another answer on this a while back too, see if you can find my post somewhere. I'll look too.
     
  8. Eterniity

    Eterniity Scavenger

    So after reinstall of windows I can now no longer open this program. I have made sure I have the most recent C++ redistributes installed and still get multiple .dlls are missing.
    It comes up with 3 VCRUNTIME140.dll was not found.
    It comes up with 1 MSVCP140.dll was not found.

    Any tips on what to do now?

    I have now manually readded the MSVCP140.dll and am able to open the program. Now all profiles say private, all people have same exact time on server. About 10% of countries do not show up. All IPs on bans are missing.
     
    Last edited: Jan 27, 2018
  9. Shotgun Teddy

    Shotgun Teddy Wood Hoarder

    Looks like your database got corrupted or something. Sorry, unless you got a backup you might as well wipe the database and start new.
     
  10. theeye

    theeye Wood Hoarder

    Hi guys. I can pull all 3 servers up and the panels. But I can't connect. Just finished loading windows updates. Any ideas out there ???? :)
     
  11. Killa 4

    Killa 4 Naked Wanderer

    Hey Vfloyd Everyone is looking for you in slack wondering if you are still want to update Rust Admin or if its possible to let someone else work on it? Would be greatly appreciated :p
     
    OniSahkkû and GhostPLKR like this.
  12. Budyzr

    Budyzr Scavenger

    Will not run. VCRUNTIME140.dll was not found missing MSVCP140/dll as well and this is from a fresh download.
     
  13. Freaky

    Freaky Shack Builder

    Code (Text):
    (09:18:45) | [Better Chat] Freaky™: test
    (09:18:45) | {
    "Message": "Freaky™: test",
    "UserId": xxxxxxxxxxxxxxxxx,
    "Username": "Freaky™",
    "Color": null,
    "Time": 1517383110
    }
    to just
    Code (Text):
    (09:18:45) | [Better Chat] Freaky™: test
    ?? I tried some options, none works.
     
  14. DdutchB

    DdutchB Naked Wanderer

    hi guys how do i reload my plugins with the rustadmin rcon tool... its new for me .
     
  15. GhostPLKR

    GhostPLKR Wood Hoarder

    reload -->o.reload name
    unload-->o.unload name

    in: "Type a command to execute
     
    DdutchB likes this.
  16. DdutchB

    DdutchB Naked Wanderer

    Thank u !
     
  17. Resistance

    Resistance Grenade Master

    Remember plugin names are case sensitive
     
  18. RESiSTANCE 2

    RESiSTANCE 2 Wood Hoarder

    where are the bans stored, i would like to transfer them over to another server if possible.
     
  19. [F1L]StarClassic

    [F1L]StarClassic Naked Wanderer

    Hi Vfloyd,.

    Thanks for creating this masterpiece of an tool! I have used it before but i am experiencing some issues right now.
    Everytime i open the app my config's aren't saved. I need to retype all my login info, and all the statistics + playerloggs etc will not save.

    What am I doing wrong this time? I've simply downloaded the zipped package, unpacked it to a decent location on my system drive en run the app.
    The app works, it just doens't seem to be saving any configs for real, eventhough it does show my newly saved config in the app, it removes it when the problem is shut down.

    Hope to hear from you soon,
    René
     
  20. NoName-Zockt

    NoName-Zockt Naked Wanderer

    Hello there!
    I have a problem with a Rust Server. Anyone from the admin team baned me with rust admin. But there is no reason to ban me. I was a admin on this server and i dont wanted to be a admin anymore. I think they banned me for leaving there admin team.

    I realy hope anyone can help me.