1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. German Hoeffner

    German Hoeffner Community Admin Community Admin

    Hi everyone,

    we are happy to announce that maintenance on oxidemod has been completed! You will probably notice that the forums is now allowing https connections and supports HTTP 2.0

    Even though we tested a big portion of the system after moving, we encourage you to report any problems here.
     
    KentEST, 38ra, adhdork and 6 others like this.
  2. Resistance

    Resistance Grenade Master

    Thanks for the update and first time I have seen you posting in all the years I have been here
     
    German Hoeffner likes this.
  3. tomhud

    tomhud Master Researcher

    thanks but dont do it again :)
     
    German Hoeffner likes this.
  4. Ryan

    Ryan Plugin Developer

    Rando pfft
     
  5. ThibmoRozier

    ThibmoRozier Scavenger

    Thanks for the update. :)
    Some downage was to be expected for such an update.
    Though it might have been nice to give a heads-up first.. :p
     
  6. Resistance

    Resistance Grenade Master

    German Hoeffner likes this.
  7. Quantum

    Quantum Master Researcher

    Just me or is the forum really slow now?
     
    Thabe and TheConnor110 like this.
  8. Ryan

    Ryan Plugin Developer

    Same here
     
    Thabe and TheConnor110 like this.
  9. German Hoeffner

    German Hoeffner Community Admin Community Admin

    Thanks a bunch! Fix'd
    --- Double Post Merged, Jan 12, 2018, Original Post Date: Jan 12, 2018 ---
    Please give us some time to tweak things. Thx!
     
    TheConnor110, Ryan and Quantum like this.
  10. iDeath

    iDeath Plugin Developer

    Took that long to apply an SSL or did you also switch hosts?

    PS: Universal Plugin thumbnail is still being served over http
     
  11. ThibmoRozier

    ThibmoRozier Scavenger

    Also enabled HTTP 2.0 (HTTP/2), which is a "new" serving protocol.
    That needs more work then "just enabeling SSL"

    Some info by Apache: https://httpd.apache.org/docs/2.4/howto/http2.html
     
  12. Evilyn Corporated

    Evilyn Corporated Shack Builder

    WaterFox (excellent FireFox fork) on this PC is having problems connecting - I'm using portable Chrome (humph) to post this. The time and date on my PC are set correctly but it looks like the connection is being interrupted from the message. See attached image.
     
  13. Resistance

    Resistance Grenade Master

    Last edited: Jan 12, 2018
  14. iDeath

    iDeath Plugin Developer

    @ThibmoRozier It's been out for over a year and comes standard in most apache bundles (php 7.0 and above) Otherwise you just install the apache mod_http2 which takes only a few seconds.

    Was just curious about what all was changed during the downtime since everything that was changed could have been done while the site was live. (Minus unmounting the apache to apply new module.)
     
  15. German Hoeffner

    German Hoeffner Community Admin Community Admin

    Let's say, moving a 250k user forum installation to a new server, moving it to a new PHP version, moving it to a new webserver, enabling SSL and then figuring out all minor bugs isn't trivial. We are experienced and kept the downtime at a minimum.

    I don't know what that is, but the most used tool for SSL checking is SSLlabs which shows all green: SSL Server Test: oxidemod.org (Powered by Qualys SSL Labs)
    Also: We're not using verisign. We're using let's encrypt and the chain is complete.
    --- Double Post Merged, Jan 12, 2018, Original Post Date: Jan 12, 2018 ---
    We can not support specific browsers. As it works in firefox, it's mostly a problem with an implementation of that browser.
     
    adhdork likes this.
  16. Evilyn Corporated

    Evilyn Corporated Shack Builder

    I will continue to investigate, but WaterFox is a 99.99% implementation of FireFox with amendments to support old classic addons as well as the new ones. It also works with 100% of other web sites except this one now... Just saying. ;) It could well be a local issue and as I said, I'll continue to investigate.
     
  17. spieleschmied

    spieleschmied Naked Wanderer

    thanks for the update!
     
  18. ThibmoRozier

    ThibmoRozier Scavenger

    Nonono, using (X/W/L)AMP stacks pre-packaged is not something ANY serious host should ever do.
    That stuff is fun for the hobby person and POC envs.
    php7.x is still a rarely used in production envs as it's a complete rewrite of php and needs to prove itself again, first.

    Apache was just an example and most ISPs would still prefer Nginx above Apache.
    And unmounting isn't the correct word to use.. :p
    To enable a module you need a service restart, to re-read a config you need to reload.

    After a very quick check I can verify that they use Caddy - The HTTP/2 Web Server with Automatic HTTPS which is one I didn't know yet.
    I mainly use GitHub - h2o/h2o: H2O - the optimized HTTP/1, HTTP/2 server as reverse-proxy to Nginx.
    But seeing this info I'd say they switched environments. :)

    Could be that they "forgot" to implement HTTP/2? ;)
     
    Last edited: Jan 12, 2018
  19. Resistance

    Resistance Grenade Master

  20. FuJiCuRa

    FuJiCuRa Plugin Developer