1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.


In-game map and minimap GUI

Total Downloads: 39,951 - First Release: Sep 8, 2015 - Last Update: Dec 29, 2017

5/5, 160 likes
  1. SycoKill3r

    SycoKill3r Naked Wanderer

    See it keeps saying [LustyMap] Your map is still being generated. Checking again in 10 seconds
  2. Bl!Zz@rD

    Bl!Zz@rD Naked Wanderer

    My problem is, that the map is not correct.
    There are difference between "low-res" and "high-res" map. The High-Res is the right map and the low-res is the wrong. how can i use the high-res map?
    beancan.io - Rust Maps
  3. SycoKill3r

    SycoKill3r Naked Wanderer

    Well 27 hours ago and still get [LustyMap] Your map is still being generated. Checking again in 10 seconds
    Hate to ask this but is there another way to show a mini map other then lusty in game ?
  4. Trippy

    Trippy Scavenger

    Just got mine working literally 10 minutes ago. I deleted the config file, the plugin file, and the files (NOT the folders) in /oxide/data/LustyMap/ . I then downloaded the latest LustyMap and harbor image. I put the harbor image in /oxide/data/LustyMap/Icons. I put the plugin in the plugins folder. I then opened the config file and disabled complex map, enabled custom map, and between the quotes next to custom map name I put "map.jpg". I then saved that config and went to Beancan.io. I typed in my seed and size then generated the map. I right clicked on the image and opened the image in new tab. I right clicked on the map image in the new tab and clicked save and named it 'map'. I then put it in my oxide/data/LustyMap directory. After that, I went to my server in game and in the console I typed "oxide.reload LustyMap" then after 5 mins typed "resetmap" then after another 5 mins I typed "oxide.reload LustyMap". After that, all 40 players had the map appear in the upper-left corner completely flawlessly. If you do exactly this and still don't see it, make sure you move around in game to be sure the map is still showing after sitting AFK (it disables if you don't move for a few seconds). Also, Relog if necessary. For anyone desperate to get a map up (like I was), do this. Any issues, just let me know and I'll do my best to help. Likes are appreciated!

    DEUSNEXUS Plugin Developer

    I tried on size, it is best left here this
    This icon is more visible on the map
  6. Monty4G63

    Monty4G63 Scavenger

    When I add markers they don't seem to show up. I've tried adding then removing them then adding again. They just aren't showing up on the map, no text or icon.
  7. MimiV

    MimiV Wood Hoarder

    Use custom map image I had the same issue with my map. Download the high res image and upload to your server
  8. romanov.alex1904

    romanov.alex1904 Scavenger

    Tell me, where else can you generate a picture of the map on the website beancan.io - Home I have previously generated map, and then delete it after the last update of the game, wanted to re-generate, but the site says error... My map - 3500 Size, Seed 1917, Level Procedural Map. Please help!!!
  9. SycoKill3r

    SycoKill3r Naked Wanderer

    I did everything you said but the map part, once i go to beancan and try to generate my map it sits there for hours on end just saying
    The map is being processed..
    Beancan - Login

    So for the heck of it i tried playrust.io and downloaded my map from there and it says
    Code (Text):
    > reload LustyMap
    Loaded plugin LustyMap v2.0.81 by Kayzor / k1lly0u
    [LustyMap] Validating imagery
    [LustyMap] Icon images have not been found. Uploading images to file storage
    [LustyMap] Downloading map image to file storage. Please wait!
    [LustyMap] Generating the main map
    [LustyMap] Unable to load the map image from file storage. This may be caused by slow processing of the images being uploaded to your server. If this problem persists unload the plugin and delete your ImageData.json data file
    [LustyMap] Generating the mini-map
    [LustyMap] Unable to load the map image from file storage. This may be caused by slow processing of the images being uploaded to your server. If this problem persists unload the plugin and delete your ImageData.json data file
    When i search for my map on beancan an it comes up with beancan.io - Rust Maps
    But thats not my map , on playrust my map is different .
    Last edited: Jan 8, 2017
  10. Dream 5

    Dream 5 Shack Builder

    Here: Beancan - Login - Some maps are showing an error on generation and from what the developer for LustyMap said, there's nothing you can do right now apart from wait for Beancan IO to push an update out.
    --- Double Post Merged, Jan 8, 2017 ---
    They're two different websites and the map could look different because a generate hasn't been requested or processed on Rust IO. There's an issue with specific seeds.

    • Wait for the map to be processed/ forced regenerated from Beancan
    • Use Rust IO's outdated map if it works
    • Use an already generated seed from Beacon > Maps.
    Last edited: Jan 8, 2017
  11. Cerberus 2

    Cerberus 2 Naked Wanderer

    i had to remove this because it was causing an error even thought the map was working and it would disconnect players "disconnecting: RPC Error: cl_receivefilepng"
  12. Dream 5

    Dream 5 Shack Builder

    Usually if I have an issue with a plugin i'll use 'oxide.unload plugin' and then go from there. I haven't encountered that issue before but it sounds like 'reset map' would of fixed it.
  13. KickRoCkSuCkA

    KickRoCkSuCkA Scavenger

    my map is working wonderful, if it is not broke why update it, :)
  14. Dream 5

    Dream 5 Shack Builder

    Well mostly, it's about updating the map, the procedural map has been updated which means the shape of the map is different because of the added docks, it's also about adding the harbor icons too.
  15. Tenaga

    Tenaga Naked Wanderer

    Please help.... i have to use beancan.io without choice?
    I can not enter the url of map of Rust: IO?
  16. Dream 5

    Dream 5 Shack Builder

    Are you trying to say you can't find your map on Rust: IO or are you having a problem with LustyMap?

    Server Name?
  17. Tenaga

    Tenaga Naked Wanderer

    [EU/ITA] LIMBO [PVE / PVP] - Modded


    My Rust server's map - Rust:IO

    I want to say how put a minimap on my server, but without beancan.io, because I wait for approval from 3 days and still nothing :(
    Last edited by a moderator: Jan 8, 2017
  18. Dream 5

    Dream 5 Shack Builder

    BeancanIO are experiencing a lot of problems at the moment from what I'm aware. Does it defiantly say awaiting approval? You could use Rust IO, simply follow the installation instructions: Rust:IO Manual
  19. [SG]JinxSwe III.XIV

    [SG]JinxSwe III.XIV Naked Wanderer

    For some reason airdrop shows on map even if set to false
  20. Evilyn Corporated

    Evilyn Corporated Shack Builder

    Added the latest version an hour ago (2.0.81) with harbors working perfectly. After a few minutes the server crashed. I started it back up again and then one of the players client Rust kept crashing with (he says) red error text on screen (no screenshots, sorry). A few minutes later and the same thing happened to a player who was in Discord with me - client crashed twice. We all had a chat and came to the assumption that it was LustyMap causing the problem, so I unloaded it and immediately the problem went away and they could both rejoin.

    I (and I assume the other players on the server) didn't get any such problem, so a difficult one to pinpoint.

    Looking through all the logs, the only error message for LustyMap I could see was in the compiler_08-01-2017.txt:-

    Code (Text):
    [SERVER v1.0.24] Started as service
    [SERVER v1.0.24] Running as service
    [SERVER v1.0.24] Got Message: Ready
    [SERVER v1.0.24] Got Message: Compile
    [SERVER v1.0.24] Console: LustyMap.cs(298,25): warning CS0219: The variable `container' is assigned but its value is never used
    LustyMap.cs(1023,17): warning CS0219: The variable `playerdirection' is assigned but its value is never used
    LustyMap.cs(24,34): warning CS0169: The private field `Oxide.Plugins.LustyMap.EventManager' is never used
    LustyMap.cs(36,23): warning CS0414: The private field `Oxide.Plugins.LustyMap.worldSize' is assigned but its value is never used

    [SERVER v1.0.24] Connection closed.
    [SERVER v1.0.24] Shutdown
    Hope this helps find the problem, but I'm leaving LustyMap off for now. My worry is that other players have been crashing out and then can't be bothered to carry on and haven't said anything. I don't want to lose any players so that's why it has to stay off.