We've moved! Join us as we continue development on our new site at umod.org!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Good day, I am new and I have a problem with oxide on a server I've just started.
    I installed oxide but I'm not able to make it load any plugin, I always see them as unloaded.
    I can see with oxide.version that is the latest version so what could be the problem?
    Thanks.

    Edit:

    In the oxide log I get this error message:

    Exception while calling NextTick callback (NullReferenceException: Object reference not set to an instance of an object)
    at Oxide.Plugins.Compilation..ctor (Int32 id, System.Action`1 callback, Oxide.Plugins.CompilablePlugin[] plugins) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.PluginCompiler.Compile (Oxide.Plugins.CompilablePlugin[] plugins, System.Action`1 callback) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.CSharpPluginLoader.CompileAssembly (Oxide.Plugins.CompilablePlugin[] plugins) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.CSharpPluginLoader.<CompilationRequested>b__17_0 () [0x00000] in <filename unknown>:0
    at Oxide.Core.OxideMod.OnFrame (Single delta) [0x00000] in <filename unknown>:0
     
    Last edited by a moderator: Feb 25, 2018
  2. Wulf

    Wulf Community Admin

    Please upload, not paste, your full Oxide logs.
     
  3. I'm sorry didn't know that, here's the file:
     

    Attached Files:

  4. Wulf

    Wulf Community Admin

    Hmmm, not sure why it's erring there, but noticing that locally with Reign of Kings as well. Will have to see why it's doing that as nothing has changed that would cause that.

    Edit: Found the reason, will release a fix shortly.
     
    Last edited: Feb 25, 2018
  5. Thank you so much for the quick reply, I'll wait for the fix.
     
  6. I've checked with several threads saying the same 'Timed out waiting for plugin to be compiled' error but can't find a solution for our server

    At first we had several plugins all not working, now i've deleted them and only put one on to test, still not working,
    I have a Reign of Kings server, version 18B and when I use oxide.version we have version 2.0.3784

    I've attached the oxide log to show the errors

    Hope someone can help thank you!
     

    Attached Files:

    • Log.txt
      File size:
      19.9 KB
      Views:
      17
  7. Hello,

    I was wondering if anyone could please help me?

    Plugins don't seem to be loading for me, i've checked the logs and i have received this following error. Could someone please advise?

    21:10 [Error] Timed out waiting for plugin to be compiled: Announcer
    21:10 [Error] Timed out waiting for plugin to be compiled: PopUpManager

    Thank you,

    Tempo.
    [DOUBLEPOST=1519594246][/DOUBLEPOST]Tried a different plugin and the same issue has occurred, i will place the log file below.
     

    Attached Files:

  8. Wulf

    Wulf Community Admin

    It will
    It will be fixed once I post the update.
     
  9. Hi Wulf.

    Thank you for the swift reply.

    Is the best course of action to wait for an Oxide update?

    Thanks.
     
  10. Thank you!
     
  11. Hello
    I have error:

    [Error] Exception while calling NextTick callback (NullReferenceException: Object reference not set to an instance of an object)
    at Oxide.Plugins.Compilation..ctor (Int32 id, System.Action`1 callback, Oxide.Plugins.CompilablePlugin[] plugins) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.PluginCompiler.Compile (Oxide.Plugins.CompilablePlugin[] plugins, System.Action`1 callback) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.CSharpPluginLoader.CompileAssembly (Oxide.Plugins.CompilablePlugin[] plugins) [0x00000] in <filename unknown>:0
    at Oxide.Plugins.CSharpPluginLoader.<CompilationRequested>b__17_0 () [0x00000] in <filename unknown>:0
    at Oxide.Core.OxideMod.OnFrame (Single delta) [0x00000] in <filename unknown>:0
    14:32 [Error] Timed out waiting for plugin to be compiled: Announcer
    14:32 [Error] Timed out waiting for plugin to be compiled: Kits
    14:32 [Error] Timed out waiting for plugin to be compiled: SurvivalEssentials

    i dont know why :/

    Can someone help me?

    PS: Folder server is C:\rok

    Best Regards
    Evil
     

    Attached Files:


  12. Hey I think Wulf is still working on it! Don't worry I'm waiting too :)
     
  13. Wulf

    Wulf Community Admin

    It was already released.
     
  14. Excuse me man but where can I download the update? On the Plugin page it's still the same from before.
     
  15. Wulf

    Wulf Community Admin

    Same place it has been, Download page.
     
  16. Appreciate it Wulf! I am downloading as we speak and will post my results shortly.
     
  17. Wulf

    Wulf Community Admin

  18. Ok Tks :)

    Best Regards
     
  19. All fixed for me!