Updater

Automatic update checking and notifications for plugins

Total Downloads: 18,918 - First Release: Oct 24, 2014 - Last Update: Oct 30, 2016

5/5, 42 likes
  1. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Yes, Oxide needs to be installed after any updates.
     
  2. DarkDreamz 2

    DarkDreamz 2 Naked Wanderer

    Omfg!! WULF! You are my hero!!
    Sorry first server hosting new to all this but thank you so much. It all worked! And I got that update.json file in the config now!thank you thank you thank you!!
     
  3. NavyChief

    NavyChief Wood Hoarder

    MOD CHANGE SUGGESTION:

    I am tired of being on my server and wondering why no one is there only to discover that the server software updated.... especially when it updates outside of the normal cadence....

    I do not use twitter (I am not a 19 year old boy) and will never use twitter.

    Is it possible to change this mod so that it detects that the server version we have and the server version available are different and then give you a warning for Rust, Oxide and RustIO??
     
  4. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    There is another plugin called "Devblog Announcer" which announces when a devblog is posted, which most of the time happens a few minutes after the client update.
     
  5. pookins

    pookins Shack Builder

    i am getting this error message (from today)
    Code (Text):
    Checking for updates... This may take a few seconds. Please be patient.
    Couldn't get the latest version of plugin Rust:IO for Oxide
    Couldn't get the latest version of plugin Built
    Couldn't get the latest version of plugin Day Vote
    Couldn't get the latest version of plugin Backpacks
    Couldn't get the latest version of plugin AutoDoors
    Couldn't get the latest version of plugin CustomAnimalSpawns
    Couldn't get the latest version of plugin Compass GUI
    Couldn't get the latest version of plugin ConnectionDB
    Couldn't get the latest version of plugin Friends
    Couldn't get the latest version of plugin Death Notes
    Couldn't get the latest version of plugin BetterLoot
    Couldn't get the latest version of plugin ConnectMessages
    Couldn't get the latest version of plugin FancyDrop
    Couldn't get the latest version of plugin Better Chat
    Couldn't get the latest version of plugin CupboardRadius
    Couldn't get the latest version of plugin HeliControl
    Couldn't get the latest version of plugin HelpText
    Couldn't get the latest version of plugin ProximityAlert
    Couldn't get the latest version of plugin Kits
    Couldn't get the latest version of plugin NoGiveNotices
    Couldn't get the latest version of plugin Inbound
    Couldn't get the latest version of plugin LimitedSuicide
    Couldn't get the latest version of plugin MonumentRadiation
    Couldn't get the latest version of plugin InventoryGuardian
    Couldn't get the latest version of plugin InfoPanel
    Couldn't get the latest version of plugin NTeleportation
    Couldn't get the latest version of plugin NoFuelRequirements
    Couldn't get the latest version of plugin RadtownAnimals
    Couldn't get the latest version of plugin QuickSmelt
    Couldn't get the latest version of plugin RainOfFire
    Couldn't get the latest version of plugin RemoverTool
    Couldn't get the latest version of plugin ShowCrosshair
    Couldn't get the latest version of plugin Rules GUI
    Couldn't get the latest version of plugin Stack Size Controller
    Couldn't get the latest version of plugin SteamChecks
    Couldn't get the latest version of plugin TrapFloors
    Couldn't get the latest version of plugin WellFed
    Couldn't get the latest version of plugin ZLevelsRemastered
    Couldn't get the latest version of plugin ZoneManager
    Couldn't get the latest version of plugin TwigsDecay
    Couldn't get the latest version of plugin Updater
    Couldn't get the latest version of plugin TurretConfig
    Couldn't get the latest version of plugin WakeUp
    and getting this message for a while now ?

    Couldn't check for updates of following plugins as they have no ResourceID set: Give Plugin, Restrict Names, PlayerRankings, StorageCleaner, WelcomeMessages

    although they all seem to be working ok
     
  6. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    The first list shows that those resource sites couldn't be reached. That happens if the plugin is no longer on oxide (unmaintained or deleted) or oxide itself is not reachable.

    The other list, indicates that the plugins did not set their resourceID which is required for identification for those. It does not harm the functionality of those plugins, but disallows the updater plugin to get their latest version.
     
  7. PatrickJr

    PatrickJr Naked Wanderer

    I don't know how easy or hard it'd be, but it'd be awesome if this plugin also was able to download the updates also
     
  8. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    That is not possible using a plugin.
     
  9. ViktorFr

    ViktorFr Scavenger

    i cant seem to grant the permission guys, i can see that plug in works on rcon but not in game :/ i keep getting this:

    (19:02:03) | Unloaded plugin Updater v2.1.1 by LaserHydra

    (19:02:03) | Loaded plugin Updater v2.1.1 by LaserHydra

    (19:02:06) | [Updater] Couldn't get the latest version of plugin Rust:IO for Oxide

    (19:02:09) | [Updater] Couldn't check for updates of following plugins as they have no ResourceID set: AutomatedEvents, Economics, MultiCupboard, NukeWipe, Skins

    (19:02:09) | [Updater]

    Following plugins are outdated:



    # ServerRewards | Installed: 0.3.93 - Latest: 0.4.0 | ServerRewards for Rust | Oxide

    (19:02:46) | Permission 'updater.use' doesn't exist
     
  10. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Check the Overview for the correct permission, not old posts in the thread.
     
    ViktorFr likes this.
  11. ViktorFr

    ViktorFr Scavenger

    what about the IDS thing?
     
    Last edited: Apr 29, 2017
  12. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    What is IDS? If you mean the ResourceId, then those would have to be added to plugins that do not have them in order for Updater to know what URL to look at.
     
  13. ViktorFr

    ViktorFr Scavenger

    im trying to find where the file is located so i can add the ID's for them manualy, but i cant seem where to add them :( im using strealine website for rust server
     
  14. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The plugin would be edited to add it. The ResourceId is from the URL of the plugin's download page.
     
  15. ViktorFr

    ViktorFr Scavenger

    found a way with notepad++ haha
     
    Last edited: Apr 29, 2017
  16. Findles

    Findles Shack Builder

    would be neat if this checked for oxide updates too
     
  17. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    That'd be an entirely different check method, which there are things that already do that such as the Catalyst extension or the Smooth Restarter plugin.
     
    Findles likes this.
  18. Pimp84

    Pimp84 Naked Wanderer

    hello maybe a stupid question but how do i update plugins. im kind of new to this stuff
     
  19. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Download them and upload them to your oxide/plugins folder, same as you do to install them.
     
  20. Pimp84

    Pimp84 Naked Wanderer

    ok but do i need to copy paste the config then so it wont change