Updater

Automatic update checking and notifications for plugins

Total Downloads: 19,531 - First Release: Oct 24, 2014 - Last Update: Oct 30, 2016

5/5, 43 likes
  1. p0rks0da

    p0rks0da Naked Wanderer

    OK, oddly it happens randomly.. almost never if you run it from the console. it will run on the timer and i will run the command from console right after and wont get the spam. Oh well.. necessary evil. gotta have it. Thanks for reply and coding!
     
  2. UkFsG

    UkFsG Wood Hoarder

    so i tried installing this oct 30 but got an error as you can see at comment 324, ive just installed it again today and im getting

    [Oxide] 14:35 [Info] Updater was compiled successfully in 1983ms
    [Oxide] 14:35 [Info] Loaded plugin Updater v2.1.1 by LaserHydra
    [Oxide] 14:35 [Warning] [Updater] Generating new config file...
    [Oxide] 14:35 [Warning] [Updater] Couldn't get the latest version of plugin Rust:IO for Oxide
    [Oxide] 14:35 [Warning] [Updater] Couldn't get the latest version of plugin ServerInfo
    [Oxide] 14:35 [Warning] [Updater] Couldn't check for updates of following plugins as they have no ResourceID set: Economics, HitIcon, Kits, PlayerDatabase, SharedDoors, WeaponsShownOnBack, Weather Controller
    [Oxide] 14:35 [Warning] [Updater]
    Following plugins are outdated:

    # Friends | Installed: 2.0.0 - Latest: 2.1.2 | Friends API for Rust | Oxide

    # Tickets | Installed: 2.0.0 - Latest: 3.1.1 | Tickets | Oxide
     
  3. p0rks0da

    p0rks0da Naked Wanderer

    This was answered a couple of posts back:

     
  4. UkFsG

    UkFsG Wood Hoarder

    i did have a quick look through the last couple of pages and missed it, up all night and now suffering the consequences. cheers
     
  5. p0rks0da

    p0rks0da Naked Wanderer

    heh heh been there done that. no worries
     
  6. Mr.Luigi

    Mr.Luigi Wood Hoarder

    keep getting this for half of my plugins lol
    Code (Text):
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Rank-ME
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Rust:IO for Oxide
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Copy Paste
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin HumanNPC
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Admin Spawn
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin AutoDoors
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Bank
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Admin Chat
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Sign Manager
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin BuildingWrapper
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Better Chat
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Better Say
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Build
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin EasyVote
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin EmptyLowFPS
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Notifier
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin EnhancedBanSystem
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin ServerInfo
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Finder
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Guess The Number
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Admin Inventory Cleaner
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin InfoPanel
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Healer
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin NTeleportation
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Kill Feed
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin MasterKey
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Playtime Tracker
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Quests
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin RemoverTool
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin RGive
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Spawns
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin StrikeSystem
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin TargetPractice
    [Oxide] 15:00 [Warning] [Updater] Couldn't get the latest version of plugin Timed Permissions
    [Oxide] 15:00 [Warning] [Updater] Couldn't check for updates of following plugins as they have no ResourceID set: Custom Chat Commands, Event Manager Menu Interface, HorseFly, Kits, PathFinding, PlayerDatabase, PlayerInformations, Inventory Repairer, SDonate, Waypoints, WeaponsShownOnBack, Where's My Corpse
     
  7. sami37

    sami37 Master Researcher Plugin Developer

    http://oxidemod.org/threads/updater.5843/page-18#post-263822
     
  8. royalrust

    royalrust Scavenger

    can this downlod the new updates t the server and update? or just tell you ?
     
  9. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    It just notifies. Plugins can't download other plugins.
     
  10. UNSC Trekman

    UNSC Trekman Wood Hoarder

    Is this plugin ever going to be updated? It's only giving me:

    (20:04:01) | [Oxide] 22:03 [Info] Updater was compiled successfully in 2258ms

    (20:04:01) | [Oxide] 22:03 [Info] Unloaded plugin Updater v2.1.1 by LaserHydra

    (20:04:01) | [Oxide] 22:03 [Info] Loaded plugin Updater v2.1.1 by LaserHydra

    (20:04:01) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin AirdropExtended

    (20:04:01) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin Rust:IO for Oxide

    (20:04:01) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin Day & Night System

    (20:04:01) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin Airdrop Arrow

    (20:04:01) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin Admin door Unlocker

    (20:04:02) | [Oxide] 22:03 [Warning] [Updater] Couldn't get the latest version of plugin SkipNightVote

    (20:04:03) | [Oxide] 22:03 [Warning] [Updater] Couldn't check for updates of following plugins as they have no ResourceID set: Helptext, Players list, ChatHead, Kits, SpawnConfig

    (20:04:03) | [Oxide] 22:03 [Warning] [Updater]

    Following plugins are outdated:



    # FancyDrop | Installed: 2.2.0 - Latest: 2.4.2 | FancyDrop for Rust | Oxide



    # HeliControl | Installed: 1.0.42 - Latest: 1.1.0 | HeliControl for Rust | Oxide



    # Prod | Installed: 2.2.5 - Latest: 2.2.6 | Prod (Who Owns) for Rust | Oxide
     
  11. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    Its pretty funny. I added those warnings so you know when there is something wrong with the plugins support for the Updater and everyone thinks this plugin is broken. Before the plugin would just not mention those.

    The few plugins which Updater wasn't able to check for, are most likely all unmaintained or have an invalid resourceID set.

    The plugins mentioned to have no ResourceID set, literally have no ResourceID set which is required to check for updates.

    So what can you do to get rid of the warnings?

    You can not do much about the unmaintained ones unless you get somebody to continue them. If they are maintained, tell the author to fix their resource ID.

    For the ones who entirely miss the resourceID, you just tell the author to add the resourceID for supporting Updater.
     
  12. Pachi

    Pachi Scavenger

    how can i add some plugins that cant find
    [Oxide] 00:43 [Info] Couldn't check for updates of following plugins as they have no ResourceID set: ConnectMessages, Kits, WelcomeMessages
     
  13. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    You'd need to report that to those plugin authors then. That isn't something this plugin would fix.
     
  14. Pachi

    Pachi Scavenger

    o i thinked that u can add it mannually ty again xd
     
  15. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    You can yourself, yes; otherwise the plugin's author would need to going forward.
     
  16. UNSC Trekman

    UNSC Trekman Wood Hoarder

    I am sorry for assuming this plugin was incorrect, when it was the discontinued plugins and others that were incorrect. My apologies.
     
  17. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    No issues. Just wanted to clear it up.
     
  18. Pachi

    Pachi Scavenger

    plugin not working ?
    > updates
    [Oxide] 18:34 [Info] Checking for updates... This may take a few seconds. Please be patient.
    > updates
    [Oxide] 18:35 [Info] Checking for updates... This may take a few seconds. Please be patient.
    > updates
    [Oxide] 18:38 [Info] Checking for updates... This may take a few seconds. Please be patient.

    still like that all the time
     
  19. Pachi

    Pachi Scavenger

    how can i add the plugin rust:io for this plugin beacause the rust:io is located in managed
     
  20. LaserHydra

    LaserHydra Grenade Master Plugin Developer

    Thats nothing you can do. I need to find something for that.