1. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    If you aren't specifying them in the command-line, yes.
     
  2. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    No joy. What is the option to put the password in the commend line. The tool is definitely see the rust server because it is generating an"unsuccessful" attempt.

    Thanks,

    Ab
     
  3. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    See http://playrustwiki.com/wiki/Server_Commands.
     
  4. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    Wulf,

    Thanks for your reply. I am familiar with that page.

    I can set up the config file, not a problem.

    I am having trouble with

    Start /high rust_server.exe -batchmode -port 28015 -datadir "save/rust/" -maxplayers 10 -cfg "cfg/server.cfg"

    I am unable to get the server to ingest the config file. can i put the rcon password in that command line.

    https://developer.valvesoftware.com/wiki/Rust_Dedicated_Server#RCON would seem to indicate no.

    Thankss for any help you can give
     
  5. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    It can go in the command-line like any other setting.
     
  6. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    I have tried:

    -password 1234
    -password "1234"
    -rcon.password 1234
    -rcon.password "1234"

    In the commend line.

    None work.

    I have my install in D:\rust_legacy

    Do I need it under the Steam install?

    For this line here:
    Start /high rust_server.exe -batchmode -port 28015 -datadir "save/rust/" -maxplayers 10 -cfg "cfg/server.cfg"

    Would "cfg/server.cfg"

    Refer to:
    D:\rust_legacy\cfg\server.cfg

    or

    D:\rust_legacy\save\rust\cfg\server.cfg

    or

    something else

    No matter what I seem to do, the cfg is ignored.

    Thanks,

    Ab
     
  7. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The path would be based on the server root, so the first one you gave. I know the option works, I and other hosts use it. What dose your server.cfg looks like?
     
  8. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    server.hostname "xLOCALx"
    rcon.password 1234
    server.pvp false
    sleepers.on true
    grass.on true

    it is located in:
    D:\rust_legacy\cfg

    My start batch:

    @echo off
    Start /high rust_server.exe -batchmode -port 28015 -datadir "save/rust/" -cfg "cfg/server.cfg"


    Output of server:
    Rustlog.png
    Note the part in yellow.

    This always displays.

    Even if I delete server.cfg altogether.

    If i put server.cfg in that location it is ignored.

    Thanks for your continued help.

    Ab
     
  9. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Ah, because you are setting the datadir, which changes it all. So yes, what the console says is right.
     
  10. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    Wulf,

    If I remove -cfg "cfg/server.cfg"

    And use:

    Start /high rust_server.exe -batchmode -port 28015 -datadir "save/rust/"

    That line:

    "Loaded save/rust/cfg/server.cfg" still appears.

    If I put the server.cfg at that location....it is ignored.

    Would you be willing to share your sanitized start bat and cfg file.

    Thanks,

    Ab
     
  11. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Yes, because the default location is that.
    Code (Text):
    @rust_server -batchmode -maxplayers 10 -port 28018 -logFile "log.txt"
     
  12. Abby Normal

    Abby Normal Wood Hoarder Plugin Developer

    Wulf,

    This is bizarre. I know how I fixed it, but I have no idea why it worked.

    I rent a server, and i had problems with the server showing up in the list of servers.

    So for whatever reason, i decided to redo the config on the serer.

    It has 2 ways you can do it:

    A config editor and a text editor. (FPSGAMES)

    I opened the text editor and deleted everything and restarted. the server was in the list as an unnamed server at that point.

    I went back in to the configuration editor and simply entered the 4 values it asks for.

    I restarted and it appeared with the name I gave it.

    If I made changes with the text editor, even with in quotes, the server would sometime disappear.

    Never consistent.

    So I left it at the 4 items and saved and made sure it appeared

    I then deleted the server.cfg for my local server.

    I then download the copy of that file from the rented server and downloaded straight to the cfg directory for the local server.

    Restarted and everything worked.

    Maybe i had some sort of stray character in the cfg file that made the rust server choke.

    But for now it works.

    Thanks for you patience, help and time.

    AB
    --- Double Post Merged, May 22, 2015 ---
    Thanks for all this.
     
  13. arman_motevalian

    arman_motevalian Scavenger

  14. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Download, extract, overwrite, and run your server likely you would any other time. CSharpCompiler is not what you use, just run it like a normal server.
     
  15. arman_motevalian

    arman_motevalian Scavenger

  16. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    I don't know why it's giving you that, but I'd just login with anonymous and see if that makes a difference. The Rust server files are public.
     
  17. arman_motevalian

    arman_motevalian Scavenger

    In SteamCMD type :

    app_update 258550 -beta legacy

    But Not Work :(
     
  18. PaiN

    PaiN Shotgun Ace Plugin Developer

    Just login anonymously... dont login with your steam
    "Once you're in the Steam prompt we start with logging in as Anonymous by just typing login anonymous, once you've done that you'll see a connecting message and licence info message popping up, after that the Steam> prompt re-appears."
     
  19. W22F

    W22F Naked Wanderer

    Hi,
    I can join my server locally on my server, but if I want to join it on my computer it won't connect on port 28015. I have opened the port in the firewall.
     
  20. oliveirarodrigocr

    oliveirarodrigocr Naked Wanderer

    hello i am facing some problem with Oxide 2.0 , some plugins or not work on server Rust Legacy , how should I install these plugins properly for no error because the server and the original stem .