1. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

    Seeing now that Oxide 1.18 has been released for everyone to download lots of people will most likely give it a go and to prevent hundreds of help topics top be opened I decided to create a step by step guide to setting up your own Rust Dedicated Server with Oxide 1.18.

    Pre-requisites
    Make sure that you install or have installed Visual C++ Redistributable 2012 x86 when trying to run your server with Oxide. If you don't have this installed your server will not run Oxide and an error message regarding lua52.dll will show up.
    Also make sure you've installed x86 and not x64, x64 will not work (however do not remove this installation if this is already present, other applications might utilize this!)

    Downloading the dedicated server
    To get started we need to go download SteamCMD, this is basically a Console Client for Steam that allows us to install and update the dedicated server files using a command-line interface. Just download SteamCMD and extract the contents of the zip file to a folder. Once you've done that run SteamCMD and you'll notice that it will start downloading an update, this is just all the required files for SteamCMD to work that are being downloaded and installed. Once this is ready you should be able to access the command-line.

    [​IMG]

    Once you're in the Steam prompt we start with logging in as Anonymous by just typing login anonymous, once you've done that you'll see a connecting message and licence info message popping up, after that the Steam> prompt re-appears.

    Now we'll set the directory where we want to install our Rust Server by using force_install_dir <path>, now that we have done this we can start downloading the Rust Server files by running the following command: app_update 258550 -beta legacy.

    Be a bit patient now since this takes a few minutes depending on your internet connection.

    Once this has finished you will notice that all the dedicated server files have been downloaded to the specified path you used in the command force_install_dir earlier.

    Adding Oxide 1.18 to the server
    To add Oxide you need to start with downloading the modded server files first, once you've downloaded these extract them to the server folder and when prompted to merge and overwrite files, confirm this. This will add the required Oxide folders and the modified Rust libraries which will load Oxide.

    Starting the server
    Now comes the easy part, starting the server. What I did was creating a .bat file which contained the parameters to run the server with Oxide including some settings like the name of the server, maximum amount of players, server port, ...
    Code (Text):
    @echo off
    Start /high rust_server.exe -batchmode -hostname "My Own Rust Server" -port 28015 -datadir "save/rust/" -maxplayers 100 -cfg "save/server.cfg" -oxidedir "save/oxide"
     
    The most important part here is -oxidedir "save/oxide" which obviously points to the Oxide folder we have just downloaded and added to our folder.

    Now save this .bat file and run it, this should launch the server and a similar window should be shown:
    [​IMG]

    Joining your server
    To join your server you just have to launch Rust, open the ingame console with F1 and type net.connect 127.0.0.1:28015. When you want to your friends to be able to join you as well you will have to use your IP instead and it will also most likely require you to alter some modem/router settings to allow traffic through the required ports.

    Good Luck and Have Fun!

    If I would've missed something, or something should be explained a bit better, please let me know and I'll alter this post :)
     
  2. Hatemail

    Hatemail Shotgun Ace Plugin Developer

    Thanks for putting this together Mughisi this hopefully will cut down on the amount of help topics like you have said. I don't think you missed anything that I am aware of.
     
    Mughisi and Wulf like this.
  3. Scrapyard Films

    Scrapyard Films Naked Wanderer

    Thank you. This finally solved all my problems. It was the /bat file i didnt have. I would load my server and Oxide looked like it was loading but as you said in my initial post, parameters were not set and it was basically loading a vanilla Rust each time. Thanks again.
     
  4. Eggster

    Eggster Naked Wanderer

    thank you for putting together this guide.
    I'm sure it will help a lot of folks out.
     
    Wulf likes this.
  5. Kainzo

    Kainzo Naked Wanderer

    How does this differ with the linux server?
     
    Last edited by a moderator: Sep 9, 2014
  6. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

    Most of it is actually the same, I do believe that SteamCMD (https://developer.valvesoftware.com/wiki/SteamCMD#Linux) works perfectly under Linux. The problem with the Legacy server is that there is no Linux version available so if you want to launch the server you'll have to use Wine. Basically the difference is the way how you start the server:
    Code (Text):
    xvfb-run --auto-servernum --server-args='-screen 0 640x480x24:32' wine rust_server.exe -batchmode -cfg "save/server.cfg" -maxplayers 100 -port 28015 -oxidedir "save/oxide"
    The above should do the trick if I'm correct (if someone with more experience with the OS could verify).
     
    Last edited: Sep 9, 2014
    Spicy and Wulf like this.
  7. Kainzo

    Kainzo Naked Wanderer

    I'm running the Linux version without wine, it seems to mostly work.

    Here's what I found.
    First off, I've looked around and there seems to be a lot of info lacking for the Linux server files (Debian).

    Here's my server install:
    /home/core/steam/rust/RustDedicated_Data/Plugins/x86_64

    I've started the server using this script:
    http://hastebin.com/ipuqojesiy.md

    Here's the output.txt log
    http://hastebin.com/cijucipuqe.vhdl
    Looks like we're sitting at "InvalidTicket" error when users try to join Linux servers
     
    Last edited: Sep 10, 2014
  8. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

    By looking at your output log I noticed you are running the experimental server, oxide is not yet available for this version. And it looks like something is going wrong with initiating the server connection to steam, only thing I can recommend is reinstalling the server. If you are indeed in need of assistance to run the experimental server on linux and it keeps giving problems I suggest asking help on FacePunch forums.
     
  9. jellomindiskandar

    jellomindiskandar Naked Wanderer

    I cant join the game... it says facepunch_connector_cancelled
     
  10. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

  11. DaCore

    DaCore Scavenger

    Hi, i have setted up Oxide 1.1.8 how the description sayd. Copyed all the files to the right Place. But when i start the Batch-File it shows me following Error:

    TypeLoadException: Could not load type 'GFxImageEffect, Assembly-Csharp'.

    I have the 1069 Server Files and edited the Batch file correctly. Did i miss anything?
     
  12. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

    This is a first time I see this one, appearantly something went wrong loading a type from the Assembly-CSharp file, so the only thing I could ask you to try for now is to just copy the downloaded rust_server_Data folder to your Rust server folder again, overwriting everything it asks to overwrite.
     
  13. DaCore

    DaCore Scavenger

    I have done all the Steps again in the corrct Order. Same result :(
     
  14. Mughisi

    Mughisi Grenade Master Community Mod Oxide Developer

    Could you post the entire logfile perhaps? Maybe there is something else in there that could hint to another problem.
     
  15. DaCore

    DaCore Scavenger

    Before we try to find the impossible, is Oxide 1.1.8 even for cracked rust servers? Cause when not, we can stop here. Simple yes or no is enough, cause i know you dont support cracked Server.
     
  16. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    We do not provide support for "cracked" servers, but even still... the Rust server files are now public and the software does not have any sort of DRM that makes your server barf errors. Most likely you have other errors or something missing.

    Generally when you see this type of error flying around, it means your server got hung up in an earlier step during loading, but preceded to try to load some things regardless. Best to start fresh (with the legal server) and go from there.
     
  17. DaCore

    DaCore Scavenger

    Hmm, i did a fresh start, not with a legal one, but fresh.^^ Anyways, i think i have to deal with it.
    I wanted to try the new Update, cause im kinda pissed from fougerite atm. nearly all Plugins giving me Errors, and if i solve one, the next pop out. too bad:(
     
  18. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The Rust Experimental server doesn't work with Oxide yet, so if you installed Oxide on it, that'd explain why it broke. ;)
     
  19. DaCore

    DaCore Scavenger

    I havent the Experimental Server;) I have the c***ed 1069 server files^^ Just a little other Question, if i download the Legacy Server Files, that are public now, are Players with c***ed Rust Clients able to join the Server, or only with payed Version.
    I promise, its the last Question about that and i really would understand if u wont Answer. Thx;)
     
  20. Eggster

    Eggster Naked Wanderer

    Dude.. I doubt you'll get help with that here..
    So far as I know, Oxide does not support piracy..