1. Spicy

    Spicy Shack Builder Plugin Developer

    Not sure whether this is in the right section, hopefully it is.

    Just wondering what, 'Do not use your client as a server, make a separate install for the server!' means on http://oxidemod.org/downloads/oxide-for-the-forest.1127/

    How would I go about doing this? Copying all of the files over to another directory?

    Thanks!
    Spicy
     
  2. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Well, actually right now it runs as a listen server, so I would ignore that for now. Eventually it'll be spawned as a dedicated server.
     
  3. Me15connor

    Me15connor Scavenger

    does anybody know how to install it? i was gunna just drag it into the forest folder but started second guessing myself on what to do.
     
  4. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The server console will only show when you're past the lobby and in the game currently.
     
  5. Me15connor

    Me15connor Scavenger

    are there currently ingame commands? or even the ability to log in as admin?
     
  6. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Not that I am aware of, it's pretty basic right now.
     
  7. Quicken

    Quicken Shack Builder Plugin Developer

    my kids want me to setup a server for this game and I am a bit confused about it. I have setup Rust, Minecraft and 7DTD but not the forest.

    Anyone have pointers? I have a windows server 2008/R2 with my other games. ideally I can set this up on its own IP/Port combo. and install Oxide and share with my kids and friends.

    looking for:
    - Instructions and tips :)
     
    blizz_maker likes this.
  8. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    To setup a server for The Forest, you'd need a Steam account that owns the game being as the game doesn't have an official dedicated server yet. Oxide makes the client into a dedicated server by disabling client features such as the audio, graphics, input, etc. All you'd really need is the client installed where you want to host it, make sure you are logged into that Steam account that owns the game, then extract the latest Oxide-TheForest.zip from the Downloads page where the game is installed. Make sure to overwrite all files! To start the server, you can customize the _start-example.bat or copy it, then just run that and it should be running shortly!

    It's not perfect yet, but we're working on it. There are still some performance issues with it that we're looking into.
     
    Quicken likes this.
  9. MeatCircus

    MeatCircus Master Researcher Server Owner

    Am I correct in assuming you cant run that server and then play on it with the same steam acct though? That's usually how it is.
     
  10. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    You actually can... if you start the client before the server. I've been handling it this way for testing. I haven't tested it on separate machines, but for the same machine it works fine. The server will also continue after you close the client.
     
    blizz_maker likes this.
  11. MeatCircus

    MeatCircus Master Researcher Server Owner

    Hmm so do I need to actually login to steam and dl it that way or is there a way with steamcmd?
    --- Double Post Merged, Oct 26, 2015 ---
    ya I dont think it'll work on a seperate machine cause I cant login into steam on both machines at the same time. It's cool though..you guys are making progress which is awesome
     
  12. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    You can download via SteamCMD, you just need to provide your username and password since the game is paid.
     
  13. Quicken

    Quicken Shack Builder Plugin Developer

    Can someone attach a steamcmd (batch file) setup for The Forest with no gui? I have a 2nd account and I want to set this up on a server. So scratching my head does that mean that there will be a player who is the server who will go into the game and die?

    also do I need Hamachi for this? I am trying to avoid another layer :)
     
  14. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The Oxide zips include a _start-example.bat.
     
  15. MeatCircus

    MeatCircus Master Researcher Server Owner

    Is that example supposed to be run just like it is except with the server name and ip changed because it crashes every time I try to run it?
     
  16. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Yes, it runs with the example. The only thing that I'd change right now is the name, as the IP and port actually have issues still.

    What is crashing with it?
     
  17. RainbowPilot

    RainbowPilot Naked Wanderer

    I had no problem getting this up and running, and by the way it runs fantastic getting much better fps on my client. I just had one quick question how do we go about saving the world? Normally the host would find a save point and choose a slot to save in. Is there a command I can type into the server to trigger a save/load in a particular slot? Thanks for any help!
     
  18. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Saving is a bit off right now. We're working on getting it to properly save and load.
     
  19. RainbowPilot

    RainbowPilot Naked Wanderer

    Thanks for the quick reply and all the good work so far. I'll check back from time to time for updates.
     
  20. SkinN õ.Õ'.|.

    SkinN õ.Õ'.|. Grenade Master Plugin Developer

    I cannot play while the server is up, I have installed the Oxide into my clients folder, and just ran the game through Steam, once I do that the server will start automatically, and in-game I can actually connect to the server, but I have no control over things, I am able to move the character around but not the mouse, and the game itself is all messed up.
    --- Double Post Merged, Nov 7, 2015 ---
    I tried copying the game files into a diff path and install Oxide on this path, the server runs well and im able to use the client normally, the issue with this is that I can't seem to connect to the server, it says is 'Waiting for the host to start the server'

    And btw @Wulf I keep having this massage spammed in the console:
    Code (Text):
    InvalidProgramException: Invalid IL code in Oxide.Game.TheForest.TheForestExtension:<OnModLoad>m__3 (): IL_0071: stloc.3