1. The tools provided in this section are provided by third-parties with no guarantees on quality or safeness. Please use good judgement and common sense when using them.

RustAdmin RCON Tool for Rust

Efficient RCON tool to manage your server and its players (written in C++)

Total Downloads: 18,829 - First Release: Sep 24, 2014 - Last Update: Jul 5, 2017

4.96522/5, 115 likes
  1. welsalex

    welsalex Naked Wanderer

    This issue is major for me. It makes it very difficult to easily check disconnected players. Also, as others have mentioned, connected times are all messed up as well!

    @Vfloyd Please can you give us some response! Would like to know this is going to be fixed!!!! I love this tool, but I regret updating it to this version. Thanks in advance for any reply! And thank you for making this program for little to no monetary return!
     
  2. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    It is not an issue with the tool, the tool works fine. Make sure your server is fully updated with Oxide and that you have rcon.web set to 0 with Rust in your startup script.
     
  3. michaelsmith2613

    michaelsmith2613 Naked Wanderer

    @Wulf, in my commandline the oxide folder is:
    -batchmode +server.ip 104.192.227.26 +rcon.ip 104.192.227.26 +rcon.port 28233 +rcon.password xxxxxxxxxxxx +server.maxplayers 40 +server.hostname "Blacklisted's Rust PVE" +server.port 28231 +query.port 28232 +server.level "Procedural Map" +server.radiation true +server.seed 653286 +server.worldsize 4000 +server.saveinterval 900 +server.tickrate 30 +server.headerImage "" +server.url "Blacklisted's PVE Rust Info Site" +server.description "Kits,Gather,TRUE PVE,Economics" +server.secure 1 +server.salt 50 +rcon.web 1 +oxide.directory "server/my_server_identity/oxide" +decay.scale 0

    HOWEVER it's true location is "104.192.227.26:28231/Oxide"
    Mods all work fine, my only problem is RustAdmin, could this error in command line affect RustAdmin?
     
    Last edited: Jun 18, 2017
  4. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Yes, because RustAdmin doesn't use the websockets version of RCON from Rust, which you're enabling with the rcon.web 1 setting.
     
  5. michaelsmith2613

    michaelsmith2613 Naked Wanderer

    Thanks, I am in contact with HostHavoc support now. However, I do not fully understand your reply???

    I asked about folder location and nothing about websockets or rcon.web.
     
    Last edited: Jun 18, 2017
  6. optikz

    optikz Scavenger

    So the current problem I'm having is my bans aren't showing in my banlist or in game chat, however they do come up in the bans.cfg As well as a problem with server population information, it doesn't show any of the info for it. I have rcon.web 0 in my server config. Can I get some help please. I'm also using rcon type webrcon.
     
    Last edited: Jun 18, 2017
  7. rustybirdsofficial

    rustybirdsofficial Wood Hoarder

    Hi :)

    when I change to anti-cheat options and save it will the options being forward to my server and how do I know it works?
     
  8. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The rcon.web setting is what the issue is as I mentioned. You need to set it to 0 if you want to use any of the older tools like this. Your issue is not Oxide related.
     
  9. optikz

    optikz Scavenger

    Can you help me with the problem I'm having please? I'm not sure what to do, after the rust update and after I added oxide to my server it seems rust admin completely messed up.
     
  10. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Sounds like you're on an old Oxide build. Make sure you're on 2.0.3323 or higher. If you have rcon.web set to 1 with Rust, you'd need to change that as that toggles the RCON type that Rust provides.
     
  11. optikz

    optikz Scavenger

    I have it set to rcon.web 0 how would I tell what version of oxide I'm on?
     
    Last edited: Jun 18, 2017
  12. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    The oxide.version command.
     
  13. optikz

    optikz Scavenger

    Yeah my server is running the current version of oxide.

    In my oxide.config.json I have this. The password is filled out, for the port should I have my server rcon port? or leave that at the default. Or should I just have this set to disabled?

    "OxideRcon": {
    "Enabled": true,
    "Port": 25580,
    "Password": "",
    "ChatPrefix": "Server"

    EDIT: I've disabled OxideRcon with rcon.web 0 and now I cannot log into rust admin at all. Doesn't connect. I've also kept oxideRcon set true and it's still not working properly.
     
    Last edited: Jun 19, 2017
  14. adhdork

    adhdork Naked Wanderer

    Still looking for some direction
     
  15. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Which version does it show? The OxideRcon set to enabled and rcon.web 0 should allow for use with this tool or even with it false.
     
  16. optikz

    optikz Scavenger

    Server is running Oxide 2.0.3326 and Rust 793

    I currently have OxideRcon disabled and rcon.web 0 and it instantly disconnects.
     
  17. SpudULike

    SpudULike Naked Wanderer

    FPS was disabled sometime ago, check the update logs for more info
     
  18. Wombat

    Wombat Shack Builder

    wrong page lolz (this can be deleted as i posted in wrong page)
     
  19. Wombat

    Wombat Shack Builder

    ok got a few problems with the rust admin here they are lol
    console/chat dose not display any chat from users in the server
    oxide tab dose nothing lol
    console tab dose not display correctly it dose not update
    ban list dose not show prev bans
    configuration/others/ auto respnse to when is next wipe dose not work
     
  20. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    For the Oxide tab, you'd need to enable the [Oxide] tags by disabling the Minimalist mode in Oxide's oxide.config.json.

    For the chat, it sounds like you're using a plugin such as BetterChat that changes the chat logging output, so you'd need to update your filter in RustAdmin to account for that, which the filter has been posted a few times in this thread.

    For the rest, unsure.