1. thomasfn

    thomasfn Developer Oxide Developer

    To install the plugin on your server, your server provider must support Oxide - else the plugins won't do anything. If you are self-hosting, make sure you already have Oxide 2 installed, else follow our tutorial to install it.
    1. Download a copy of the plugin you wish to install. They can be found in the Resources section.
    2. If you aren't hosting locally, connect to your server via an FTP client.
    3. Locate the "plugins" folder, normally located at serverdata/oxide/plugins. If you can't find it, you may need to install Oxide still. If you already have, make sure your server has been launched at least once.
    4. Upload the plugin into the "plugins" folder.
    5. Configure the plugin by editing the matching named .json file, normally located at serverdata/oxide/config. If you don't see any configuration file for the plugin, then it either does not have one or the plugin did not load successfully.
    The plugin should take effect immediately. If it does not, ensure your server provider supports Oxide and that Oxide is installed on your server. You can also check for errors under the logs folder.
     
    Last edited by a moderator: Apr 10, 2016
    thoomasfn and Richii like this.
  2. nuno lopes

    nuno lopes Naked Wanderer

    Thanks for the post!

    Is there a way to activate a plugin without restarting the server?

    Thanks.
     
    thoomasfn, Richii and Ewth like this.
  3. Rynea

    Rynea Naked Wanderer

    Will storing lua scripts inside a (sub-)folder screw with the plugin?
    For example if theres a plugin abc and I want an extra folder for it for a path of something like this:

    /plugins/ABC/abc.lua

    Would that currently work?
    It might not be a big deal right now with a handfull of plugins, but when things get filled up with more plugins, it might be interesting to group them etc.
     
    thoomasfn and Richii like this.
  4. thomasfn

    thomasfn Developer Oxide Developer

    Plugins inside sub-folders won't get loaded.
     
    thoomasfn and Richii like this.
  5. Justice4@ll™

    Justice4@ll™ Naked Wanderer

    Hi lads since Multiplay is not supporting this Mod can you pup a Tutorial on how to apply the plugins and to get the commands to work. Cheers
     
    thoomasfn and Richii like this.
  6. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    thoomasfn and Richii like this.
  7. Sabrick

    Sabrick Naked Wanderer

    How do administrators get access to admin commands like banning and such? I see no explanation for that anywhere.
     
    thoomasfn and Richii like this.
  8. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Please do not post your question in every thread. You already have a thread and reply in another thread.
     
    thoomasfn and Richii like this.
  9. Zack

    Zack Naked Wanderer

    I am deleting this question and opening up a thread. thanks. zack
     
    Richii likes this.
  10. ambient

    ambient Naked Wanderer

    Last edited by a moderator: Jan 20, 2014
    Richii likes this.
  11. Vandarix

    Vandarix Naked Wanderer

    Thank you, This helped.
     
  12. Éverton Fernando Bote

    Éverton Fernando Bote Naked Wanderer

    Gostaria de usar os pulgns em meu servidor mais oq preciso instalar para usar não é o ''Instalando plugins no seu servidor''
    ele não esta diponivel oque fasso?
    Estou perdido por aqui!
    me ajudem

    Moderator edit: English translation.
    I would like to use the pulgns in my server more q I need to install to use is not the '' Installing plugins on your server ' ' he's not diponivel what Faso? I'm lost here! help me
     
  13. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    English please.
     
  14. Éverton Fernando Bote

    Éverton Fernando Bote Naked Wanderer

    Would you like THE USE them pulgns My Server Install More oq need subparagraph USE Não And Installing plugins'' not'' Your Server
    element Location: Not WHAT THIS addtional Faso?
    I am lost here!
     
  15. vinnie919

    vinnie919 Naked Wanderer

    anyway to install this and not restart server? or is there a way after restarting to reload to your previous time before restart? I really don't want to force everyone to start over again. Anyway around it? Thank you
     
  16. Felipe Fernando

    Felipe Fernando Naked Wanderer

    What Óxido ?
     
  17. Matt F

    Matt F Naked Wanderer

    I need help getting Oxide running with mods. I have literally tried everything to get it going and spent hours so far. I followed directions to a (T) put the files in the oxide plugins folder, rebooted, and nothing happens. Ive checked the log file and nothing. Ive removed oxide, reloaded and tried again and still nothing. Any help would be greatly appreciated. Thanks in advance.
     
    nzchick likes this.
  18. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Generally that means you do not actually have Oxide installed. Steps and outcome may vary by GSP setup a bit. Logs and what GSP you use would be useful.
     
  19. Matt F

    Matt F Naked Wanderer

    Sure no problem any help is great at this point. Its FPSplayers. I have Oxide 1.10 installed as of today, and its part of my servers feature to add it. It says installed, it created the folders where they should be as far as i can tell. As per the instructions on these forums i download the plugin .lau and copy them into the plugin folder using FTP folder access. Reboot the server and viola ? Is there a step i am missing ? Thanks in advance for your help
     
  20. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Make sure you put them under the folder where oxidecore.lua is, under save/??/plugins.