1. Cataclysme

    Cataclysme Master Researcher

    Guys stop talk about Linux or Windows please, always create conflict :p

    At the beginning, we talk about server lagging. Seem be solved by change the value of tickrate, need to restart server later to see. I was with 10 in value for 60 players on Modded so..

    I post here if continue to lagging or not for other players with same trouble
     
  2. Smabezo

    Smabezo Scavenger

    So, what is your new value? and for how many users?
     
  3. Cataclysme

    Cataclysme Master Researcher

    30 for vanilla server with ~20players
    50 for modded server with ~50 players

    But I do some test, maybe value change later
     
  4. Shady757

    Shady757 Airdrop Stalker Plugin Developer

    For what it's worth, I've noticed a strange issue recently. Whenever you upgrade or rotate (worse when upgrading it seeems) a building block (e.g wall) on a fairly large base (4000-5000+ entities or so in my testing), it seems to create a large lag spike. If you do this with less than a 3+ second pause, it seems to cripple the server quite a bit.
     
  5. Cataclysme

    Cataclysme Master Researcher

    Sounds like my new post ? Placeable items, building plan with fairly large base lag spike

    But, it's ok for fairly large base if they are empty

    But large base with 4000 walls 3000 floors 1000 foundations = horrible lag
     
  6. Shady757

    Shady757 Airdrop Stalker Plugin Developer

    Your new post seemed to indicate client-side FPS drops, though. What I was referencing is purely on the server. I took a rather small look at what Rust does exactly when rotate/upgrade is called and it seems to refresh entities surrounding it, which I imagine is the cause of the server-side performance drop (unless it's somehow just me, but I tested without plugins).
     
  7. Cataclysme

    Cataclysme Master Researcher

    When we take building plan or placeable items we have lag spikes too like 2-3 seconds too

    Maybe when we take it on our hands, Rust load average entities and create this issue ?

    I can find with you the problem and do some tests but I don't know how to find hooks called when rotate/upgrade is called

    Did you tried to use building plan or shotgun trap at the same place you lag when rotate/upgrade ?

    My players said: when rotate/upgrade too they have lags