1. Oxide for Rust Legacy has been discontinued and is no longer supported. No updates or additions will be made, and Rust Legacy-specific plugin submissions will no longer be accepted. We recommend upgrading to the latest version of Rust as able.
    Dismiss Notice
  1. trax

    trax Scavenger

    Hello,

    I installed rust legacy server fresh with newest oxide mode. But i cant load lua plugins.
    Can someone help me please?

    Log:
    Code (Text):
    11:17 [Error] Failed to load extension Oxide.Ext.Lua (DllNotFoundException: lua52)
    11:17 [Debug]  at (wrapper managed-to-native) KeraLua.NativeMethods:LuaLNewState ()
      at KeraLua.Lua.LuaLNewState () [0x00000] in <filename unknown>:0
      at NLua.LuaLib.LuaLNewState () [0x00000] in <filename unknown>:0
      at NLua.Lua..ctor () [0x00000] in <filename unknown>:0
      at Oxide.Ext.Lua.LuaExtension.InitializeLua () [0x00000] in <filename unknown>:0
      at Oxide.Ext.Lua.LuaExtension.Load () [0x00000] in <filename unknown>:0
      at Oxide.Core.Extensions.ExtensionManager.LoadExtension (System.String filename) [0x00000] in <filename unknown>:0
    Thx
     
    Last edited by a moderator: Aug 30, 2016
  2. Wulf

    Wulf Community Admin Community Admin Oxide Developer

    Install Visual C++ 2013 x86, that should be all you need.
     
  3. trax

    trax Scavenger

    Visual C++ was installad, i forgot to reboot :)

    Ty Wulf
     
    Wulf likes this.